Application Menu incomplete


#1

Hello, I’ve installed Debian 10 with LXQT 0.14.1 on my laptop and I’ve installed a few applications, including Gimp, Inkscape, MuseScore 2, VLC, and more. For some reason, VLC doesn’t show up in the application menu (all the other applications do). I also cannot find VLC if I open PCManFM-Qt and try to right-click a file and follow “open with” > “other applications”.

Does anybody know why is this the case and how to solve it?


(Pedram Pourang) #2

See the folder ~/.local/share/applications and also the files ~/.config/mimeapps.list and ~/.config/lxqt-mimeapps.list if they exist and remove any trace of VLC from them.

If the problem is not solved, VLC may have been packaged badly or may need a re-install.


(Stefano) #3

Looks like there is the vlc.desktop file missing.

/usr/bin/vlc

starts it?


(Alf Gaida) #4

@stefano - erm!

~% sudo apt-file search  usr/share/applications/vlc                                                                                                               
vlc: /usr/share/applications/vlc.desktop  
vlc-plugin-bittorrent: /usr/share/applications/vlc-plugin-bittorrent.desktop


(Alf Gaida) #5

EDITH says: I installed vlc the first time in years, because i don’t like the interface - so it seems to work :smile:


(Stefano) #6

Well, I know, I have it well in the menu in my debian10 32 bit installation too. But I see no other explanation: or it’s missing or the menu didn’t update.


(Alf Gaida) #7

@stefonarch: No problem, no bad words, no critics - but for the next answers we have standard tools:

  • apt-file search $foo or path/$foo will show the package ($bar) in charge (not installed as default)
  • apt policy $bar - will show the installation status of $bar

so my guess is: VLC isn’t installed


(Alf Gaida) #8

bah, deleted my post unfortunately - but one thing remains true:

  • the package is installed or not
  • we in LXQt don’t take care, we just show the things
  • @tsujan is right - if we don’t show the reason is that it is blocked :smile:

It’s just easy as that. (And i really hope that we are able to scan ‘usr/share/applications’ correctly’ - Until now i really found no evidence that we don’t.


#9

That folder was empty. Of the two files, only the first exists and it doesn’t mention VLC.


(Pedram Pourang) #10

We do.

I’ve had VLC since time immemorial and there’s no problem. The problem mentioned here is personal.


(Pedram Pourang) #11

Then, your VLC installation has problem.


#12

If I use the runner, I can type /usr/bin/vlc (it also autocompletes when I only type vlc and it starts VLC without any problem.


(Stefano) #13

So it’s installed. Check cat /usr/share/applications/vlc.desktop

if it doesn’t exist you can create it, could paste a copy here. If it exists the menu isn’t updated correctly.


(Alf Gaida) #14

And i suggest hereby with my Debian Maintainer Hat on to do nothing - i will not go after things i can’t reproduce.

Edit: @stefonarch - a restart would be enough - and i would still see no reason to spend just a second more on it.


#15

Thanks, that must have been it. I decided to reinstall and vlc now shows up under Sound & Video. I should have probably tried that earlier!

I don’t exactly know why it now works, because I installed vlc a few months ago and restarted this laptop many times. Perhaps I marked the wrong ‘umbrella’ package the first time and not every necessary package was pulled in if that makes sense.

Anyway, thanks to all who replied! Your help is much appreciated!


(Pedram Pourang) #16

Something like that happened for me only once in 15 years and I think I inadvertently deleted a file when I was drowsy because files don’t disappear by themselves on Linux,


#17

I know. I guess that’s also why I didn’t try a reinstall myself. I’m used to Linux always being very consistent, so trying something again normally doesn’t lead to a different result.

Anyway, the more I think about it, the more I’m convinced that I probably installed individual components of vlc instead of simply a meta package. Too long ago, but it seems to be the only logical explanation. I really didn’t do any tinkering on this install.

Thanks again!


(Pedram Pourang) #18

You’re welcome.


(Stefano) #19

Sure, I’m not very expert in all of apt features, using mostly arch/pacman. And I wouldn’t also know the available tools in fedora or suse… my way is maybe not the orthodox one always. But I’ll try to remember those commands :slight_smile:


(Alf Gaida) #20

@stefonarch - and i have no plan about any linux (or *nix) :smile: