Changing the Login theme


(Ken) #1

I’d like to know how to change the Login theme ? I use Arcolinux as my operating system.


(Chris Wyatt) #2

You need to find out what desktop manager Arcolinux uses, e.g. SDDM, LightDM etc… It isn’t a part of LXQt.


(Stefano) #3

You mean “display manager” :wink:


(Pedram Pourang) #4

Yes, it’s called “display manager” or, sometimes, “desktop display manager”.

LXQt can be used with any display manager. So, as @chriswyatt said, this question is about display manager, not LXQt.


(Chris Wyatt) #5

I was just testing you


#6

My main computer runs Arch, and I have ArcolinuxD on my main laptop and a VM. I have LightDM as the display manager on all of them. Both Arch and AcrolinuxD are sort of build it yourself systems, so it’s up to you which Display Manager you choose to install, but if you are already running LXQt, maybe because you installed Arcolinux LXQt, then the display manager would of course be installed, and I’d guess it’s LightDM. Use pacman -Ss or yay -Ss to see. If you see

community/I 1.2.2-3 [installed]
    Settings editor for the LightDM GTK+ Greeter

also installed, a LightDM settings manager will appear in the LXQt Configuration Center (at the bottom under System Settings). This is a GUI where you can make some adjustments to the LightDM display manager like choose fonts, themes, background images. It should be as easy as going to the LXQt Configuration Center,

Preferences --> LXQt settings --> LXQt Configuration Center and choose LightDM GTK+ Greeter settings

However, in my Arch or Arch based installs like AcrolinuxD this doesn’t work. Not sure why. I believe I saw it working on other distros though.

However, from CLI, entering sudo lightdm-gtk-greeter-settings or lxsudo lightdm-gtk-greeter-settings will bring up the interface.

The GUI makes things easy, but if you want to make more comprehensive adjustments to the LightDM display manager, edit the configuration files in /etc/lightdm directly. If you are in fact using a different display manager, you’ll need to find the respective configuration files.

BTW, Arcolinux provides its own version of the LightDM files in the Arcolinux repository which might do more. No personal experience here.

Personally, I really like LXQt and I’ve found LXQt goes very well with Arch. I hope you’ll give it a chance. There are one or two small instances where some tweaking is needed that I won’t go into too much here. For example when I installed LXQt with Arch or Arcolinux it didn’t install Xscreensaver. I’m OK with that because I happen to dislike Xscreensaver, preferring i3lock or dm-lock or others, but if you want “Lock Screen” to work in the LXQt menu, you’ll have to tweak the appropriate files to use i3lock or whatever or install Xscreensaver if you like it.


(Ken) #7

Thanx everybody for all your help ! Using commandline Sudo or Lxsudo worked, once I got it running I was able to change the Theme. I am very grateful for the help ! Have a great day n!


#8

Glad it’s working. I tested LightDM GTK+ Greeter settings in the LXQt Configuration Center of a Sparky Linux LXQt version install and it worked flawlessly. Since Sparky is naming it their LXQt version perhaps they made the effort to get it right. Unfortunately that doesn’t work in Arcolinux or you would have had an easy answer that was also LXQt related.
I remember some time ago having a similar issue with pcmanfm-qt where, if I chose “Open as Root” from the Tool menu and entered my password when prompted, nothing would happen. But after changing the Switch User Command to “lxsudo dbus-run-session %s” in the preferences, everything worked as expected. Perhaps something similar is going on here. It’s also an interesting question as to what is the best display manager for LXQt. I’ve always used LightDM and found it to be the default for many distros that try to be easy on resources. On the other hand the Arch wiki recommends SDDM for LXQt.
Perhaps because it’s QML based? My Fedora LXQt version uses SDDM. I find it a little slower on older hardware than LightDM.


(Pedram Pourang) #9

That problem was related to dbus and wasn’t specific to pcmanfm-qt. It first appeared on Arch years ago and then other distros, one by one. It was fixed in 0.14 by using an appropriate default command.

Any DM works with LXQt, even GDM. I use SDDM because it’s being actively developed by KDE devs but I also tried LightDM and liked it.

KDE is turning into QMLDE :wink: Yes, SDDM is slower than LightDM, even on powerful computers.


(Stefano) #10

Hm, here on arch it’s still not working, because it would need dbus-launch

lxsudo dbus-launch pcmanfm-qt %U


(Pedram Pourang) #11

dbus-launch belongs to one of Arch’s core packages, namely dbus.


(Alf Gaida) #12

And please don’t use dbus-launch anymore :smiley: https://lists.debian.org/debian-devel/2016/08/msg00554.html and

and https://github.com/lxqt/pcmanfm-qt/issues/958#issuecomment-491472534 ff

so we never ever should recommend dbus-launch, we should recommend dbus-run-session instead to prevent problems when we finally want to use wayland …


(Pedram Pourang) #13

Oh, yes, my mistake! The default is lxsudo dbus-run-session -- %s since 0.14; dbus-launch is history.


(Stefano) #14

Well actually I never use this feature, it’s just only for testing. When I use it in pcmanfm-qt the command (copied from lxsudo window) isn’t either dbus-launch nor dbus-run-session but just lxsudo pcmanf-qt and doesn’t work of course. But it’s kind of OT here, just stumpled upon this here and looked again, finding that nothing happens.


(john smith) #15

hello,

Thank you so much for your reply, it helped me alot

Thanks and regards.:slight_smile:


#16

Wow! It’s been awhile since I wrote that. Encouraging to know it was helpful. Thanks for letting me know. Curious for an answer myself, from there I opened a topic at the ArcoLinux forum, and with Erik Dubois, a developer there, explored some possibilities, and we both found the LightDM GUI worked in some situations and not others. Since we didn’t arrive at any conclusions I didn’t report back here. We were exploring possible polkit conflicts among other things here. But now I have just installed LXQt over a fresh Arch install, with Kwin as WM. There are no other DEs except OpenBox, which LXQt seems to install for use as a WM in the event no other WM is available. And the LightDM GUI still won’t open! With only two versions of polkit installed

yay -Ss polkit | grep -i installed
extra/polkit-qt5 0.113.0-1 (73.1 KiB 321.0 KiB) (Installed)
extra/polkit 0.116-3 (387.6 KiB 1.8 MiB) (Installed)

With only two, I’m thinking it’s less likely a polkit conflict is the culprit. Perhaps it’s something like the pcmanfm-qt problem explored earlier in this thread. Anyway, not sure where I’d go to check something like that out and needing to do other things, it’s been a problem on hold for me. Fortunately, the login screen files can easily be edited.