Desktop switch shortcut


#1

Dear all,

I have Disable “Global Keyboard Shortcuts” so I can use most of my old lubuntu18.04 shortcuts using openbox file (lxqt-rc.xml). (I am using Lubuntu 18.10)

However, there are two shortcuts that I personally use (well, used) a lot that are not working (because it depended on LXDE):

  • switch desktops with ‘ctr + alt + left/right’.
  • make the menu appear (so I can browse it with the keyboard)

Any ideas / suggestions on how to make this lxqt user happy again? :wink:

Regards, Jofre


(Pedram Pourang) #2

LXQt has nothing called “Global Keyboard Shortcuts”

Has always worked here. You might want to search for a problem in your config or, maybe, in lubuntu.

Alt+F1


#3

Thank you for taking the time to reply.

What I did was: Menu–> Preferences --> LXQT Settings --> Session Settings --> Autostart --> Disable “Global Keyboard Shortcuts”

The config file for those shortcuts can be found in ~./config/lxqt/globalkeyshortcuts.conf

Because I disable, the shortcuts you mention do not work anymore…


(palinek) #4

AFAIK the ‘CTRL+ALT+left/right’ are openbox shortcuts and no LXQt component does steal these. Example of openbox configuration follows:

<!-- Keybindings for desktop switching -->
<keybind key="C-A-Left">
  <action name="DesktopLeft">
    <dialog>no</dialog>
    <wrap>no</wrap>
  </action>
</keybind>
<keybind key="C-A-Right">
  <action name="DesktopRight">
    <dialog>no</dialog>
    <wrap>no</wrap>
  </action>
</keybind>
<keybind key="C-A-Up">
  <action name="DesktopUp">
    <dialog>no</dialog>
    <wrap>no</wrap>
  </action>
</keybind>
<keybind key="C-A-Down">
  <action name="DesktopDown">
    <dialog>no</dialog>
    <wrap>no</wrap>
  </action>
</keybind>

#5

Ups!!!

I do not have those lines but: left no right no up no down no

The funny thing I just discover is that the left/right are nor working… but the up/down are working! Not sure if to mark as solved…

In any case, thanks for trying! So far the lxqt forum has been very responsive! Thanks