Detailed guide to enable High-DPI-scaling on LXQt


(Kreyren) #21

Any way to set this using a config file? (prefers to make a comments so that i know what is each var doing.)

EDIT: The variable doesn’t seem to work? Tested in LXQt Configuration Tools with value 2,12 212 (logout and invoked startx for each change.)

EDIT2: Noticed %20 in session.conf in QT_SCALE_FACTOR. that’s probably causing the issue, checking.


(Pedram Pourang) #22

It goes in ~/.config/lxqt/session.conf but you don’t need to edit it manually when you can set it with LXQt Session Settings.


(Pedram Pourang) #23

It works flawlessly.

There isn’t such a thing in a clean LXQt installation.


(Kreyren) #24

i meant that if QT_SCALE_FACTOR& where & is space it translates to QT_SCALE_FACTOR%20 -> results in syntax error (lxqt-meta-0.13.0)

reproduced twice, should be probably highligted if space is present in a variable or output error.

(i’ve copypasted var from ±Comment #1 and missed the space)

overall solved, thanks for help


(Pedram Pourang) #25

Why should you add & ?! %20 doesn’t make sense. Do it in the normal way and you’ll encounter no problem


(Pedram Pourang) #26

And the latest LXQt is 0.14.


(Kreyren) #27

& is space so VAR& results in VAR%20 if parsed in Session Settings on lxqt-meta-0.13.0 (on my system).

Noted version, will update.


(Pedram Pourang) #28

OK. As you found out, there should be no extra space.


(Kreyren) #29

Noted, but i believe that it’s hard to notice especially for someone who does not set variables manually -> recommended to highlight it or output err if present to prevent confusion on end-user assuming not fixed in 0.14. (feedback)


(Pedram Pourang) #30

Yes, it’s better to add it (and add a tooltip for it) because it’s an important Qt EV. It was discussed before.


(Pedram Pourang) #31

As for an output err, it isn’t needed. What you did was very strange :wink:


(Kreyren) #32

noted, ty for info