Detailed guide to enable High-DPI-scaling on LXQt


(Alf Gaida) #41

Acer EB0 EB550K or iiyama LE5540UHS-B1 55" - first models are available :smiley:


(Alf Gaida) #42

re kwin - i have a maybe dumb idea (totally nuts, but should work) - had to tinker a bit next days.


(Ivan M.) #43

LOL, I just revamped the discussion :slight_smile: . BTW Thank you guys for your answers.

It’s quite difficult, No Gimp, No Inkscape.

I do completely agree, in fact I also wrote: is not even close to the nice Qt scaling.

Precious hint, Thx.

@agaida did you managed to scale gtk3 apps with GDK_SCALE? It doesent work for me. What kind of distro are you using?

@tsujan this is a screenshot with gimp (gtk2), gnome-disks (gtk3), pcmanfm (Qt) on my display. The word File on gimp menu is 3mm wide.


(Alf Gaida) #44

- as i said, i use no scaling, but i need a bit bigger screen :smiley: And i use Siduction with latest git.


(Pedram Pourang) #45

pcmanfm-qt, lxqt-panel and lxqt session settings seem OK in your screenshot.

Neither GIMP nor gnome-disks is scaled by GDK_SCALE. OK, I don’t expect GIMP and Inkscape to be scaled but gnome-disks is based on GTK3. It seems that it isn’t as simple as GDK_SCALE for GTK3 but I have no knowledge of GTK3 (should search Internet if I find the time).

As for openbox, I also think you could scale it by using an appropriate theme, as you mentioned above. KWin title-bar can be scaled easily by changing some settings of Breeze or its forks.


(Pedram Pourang) #46

@Ivanicchio

This is GDK_SCALE=2 gnome-disks:

As you can see in the screenshot, it’s scaled correctly with GDK_SCALE – like Falkon with QT_SCALE_FACTOR.

I don’t know why it isn’t so for you.

EDIT: Try to remove GDK_DPI_SCALE.

EDIT2: Is this on VirtualBox?! If so, your problem with GTK is a virtualbox issue.


(Ivan M.) #47

Cooool… you make me thinking about a new display. :sunglasses:

Never heard about Siduction. I’m definitely gonna investigate a little bit.

Yep! my fault. I just wanted to be sure of LXQt capabilities before installing… Let me get it properly installed than I give you a feedback.

…In the meantime created a fresh new user (on the same virtual machine) and set QT_SCALE_FACTOR=2 and GDK_SCALE=2. gnome-disks is still small when started from menu. If I launch it from terminal it gets the correct size but with wrong system theme, So, I think it’s definitely a Lubuntu issue. As @agaida said it’s probably a matter of time to get the whole puzzle done.


(Pedram Pourang) #48

Now I can confirm this part. Last night, I didn’t have access to my test computer. Today, I set GDK_SCALE to 2 in LXQt session settings, logged out and logged in. gnome-disks was small when run from the main menu but it was OK when run from terminal or pcmanfm-qt. Please report that at https://github.com/lxqt/lxqt-panel/issues Thanks in advance!

I cannot confirm this. It may be a Lubuntu issue. With GDK_SCALE set to 2 in LXQt Session Settings, gnome-disks is OK when run from terminal or from pcmanfm-qt (by clicking its icon in /usr/share/applications).


(Pedram Pourang) #49

No, it was my fault. As I said above, I didn’t have access to my test computer and supposed that, when it was OK in terminal, it should be OK in main menu too. I was wrong.


(Ivan M.) #50

Just tried to launch gnome-disks from pcmanfm-qt. Every application in there has a big exclamation point on its icon. None of them are launching. Gosh! The more we dig the ‘better’ we get…


(Pedram Pourang) #51

If you have a standard LXQt installation, you shouldn’t see any “exclamation mark” inside /usr/share/applications. In other places, it should exist and you could remove it by right clicking and checking “Trust this executable”.

Anyhow, the “exclamation mark” shouldn’t prevent you from launching anything; it just shows a prompt dialog.


(Pedram Pourang) #52

BTW, if you test in VirtualBox, why Lubuntu? To have a standard LXQt experience, you could install Debian Buster (Testing) LXQt ISO.


(Ivan M.) #53

True, It’s just because I use Lubuntu since 2010 for production purposes.I am quite reluctant to learn how to get new distros up and running (in the past I had redHat, fedora, ubuntu, arch, gentoo and many other distros). Now I need to get my hosts up and running in a fast and reliable way. I will follow your advice though I will try Debian (which is actually not that far away from lubuntu) Who knows, maybe it’s time for a major change.


(Pedram Pourang) #54

If you see “exclamation marks” in /usr/share/applications or if the mark doesn’t let you launch a desktop entry in other places or can’t be removed by right clicking, provided that you have the latest Lubuntu installed, you could report it at launchpad because none of these is an LXQt issue.

Ubuntu has prevented its users from experiencing a standard Gnome/KDE/LXQt/… session and developers from knowing what’s a real issue and what’s an Ubuntu issue. Whether it has stopped doing so with LXQt is something we should wait to see (I know it hasn’t stopped in the case of Gnome).

But you were right about LXQt main menu not respecting GDK_SCALE. I’ll test it again later.


(Ivan M.) #55

I agree with you. The exclamation mark problem is a minor issue that doesn’t deserve to get an in-depth investigation as it is at an early stage of development. In the end I got some applications launching and some not, but now, I want focus myself on -getting a consistent DE over several tool kits-.

As you pointed out starting from a vanilla LXQt DE is the best practice. I will do that so we could at least have consistent feedbacks and inspecting methods.


(Pedram Pourang) #56

It isn’t :slight_smile:

BTW, if you find any bug in LXQt, please report it, provided that it isn’t already reported. It isn’t important whether a feature is new or old.