Featherpad shift-insert paste changes to overwrite mode


(James) #1

In featherpad, if I paste the clipboard using shift-insert, it changes to overwrite mode (if I’m in insert mode, it changes to insert mode if I am in overwrite mode.


(Alf Gaida) #2

Use the latest release. Done. If your distribution not provide such things build the packages yourself or change the distribution.


(Pedram Pourang) #3

This bug was already reported and its fix is in V0.9.4: https://github.com/tsujan/FeatherPad/commit/49180c21fce3484f8a863f7e17bbdc076ee000fb

V0.9.4 is the latest git version and isn’t released yet. So, if you want the fix, you have 3 options: use the latest git, or apply the patch manually, or wait for the next release.

FeatherPad’s bug tracker is separate from that of LXQt and is https://github.com/tsujan/FeatherPad/issues.


(Pedram Pourang) #4

@agaida Should I release 0.9.4 for Debian stable?


(Pedram Pourang) #5

Released it anyhow because, apart from YAML and Fountain support, the remaining changes were bug fixes.


(Alf Gaida) #6

fine, i will do the translations only point releases tomorrow and upload featherpad too

Edit: Just packaged and uploaded, will be available in approx 6-8h in debian/sid