Is rendering my computer completely unusable MATE's fault or LXQt?


Is rendering my computer completely unusable MATE’s fault or LXQt?

The scenario:

I install a fresh MATE 18.04.1. Works fine after reboot.

I install LXQt to try it out.

$ sudo apt-get update
$ sudo apt-get install lxqt openbox

I logout, get the login screen, I choose the lxqt option from the dropdown mentu to try it out.

I get this window:

“Welcome to LXQt Please slect your default Window Manager.”

and the options are:

“Other… Chose your favorite one”

And that’s the only option. What the hell do I do with that? Underneath:

“You will be able to change this at any time through Preferences -> Session Settings -> Basic Settings.”

With one button “OK”

There’s no cancel button. That’s the only button.

What do I do? I guess I’ll reboot, right. I reboot. I get the same window. (I guess because in the MATE install I told it to auto-login.)

Thus my computer is completely useless. What is my other recourse but to reinstall MATE. I reinstalled MATE. Here I am. Good thing I hadn’t set it all up and installed stuff and THEN thought hey gee golly maybe I’ll try lxqt.

(I’ve been a lamp developer for 20 years and I did crtl-alt-F4 to get a command prompt, but hey, pretend I wasn’t; pretend I was a beginner or intermediate. So in fact, I didn’t bother trying to needle around to fix it, it’s not worth my time. Why should I fix some shitty distro and/or window manager.)

Which brings me to my original question:

Who’s at fault here? Is that MATE’s fault, or is that LXQt’s fault?

Which one should be responsible for not providing me a cancel button? I want to know who to avoid forever.

Thank you,

(Alf Gaida) #2

First: There is no fault - you installed some packages and choose LXQt as Desktop to start. Because there are more than two Window Managers installed and both are not configured for LXQt the LXQt session ask which one to use. So you should search for marco or openbox and select one - thats all.

And there should be no problem to choose the Mate session and start it.

(Jim Shriner) #3

Wow Bog, you worked way too hard to try out LXQt, only to end up where you started. Sorry to hear that. I’m not a developer, just a fan of LXQt and the direction it’s going. I understand your frustration, but if you learn something from the process, maybe it makes it worthwhile? I’m reminded of the famous quote “experience is what you get when you didn’t get what you came for”. For future reference (if you ever give LXQt a go again?!), you were right there…you were 1 click away from success! When you get to this place:

All you have to do is navigate to the usr/bin/ directory and select the window manager of your choice! In your case “openbox”. But LXQt is designed to be WM-agnostic, so you could’ve selected the Mate WM (marco? or mutter?), or kwin or xfwm4 or fluxbox or…whatever you prefer that you have installed. A “cancel” button makes no sense at this point, as you MUST have a window manager selection for LXQt to function, but perhaps a “hint” to navigate the usr/bin directory for “undiscovered WMs” is a valid suggestion to developers? But once you select your preferred WM in the initial setup, you’re good to go for all future LXQt sessions, unless you want to change WM; in which case you navigate back to the LXQT preferences and repeat the process for a different WM.

Sorry you went through all those gyrations, but now that you know, I hope you’ll give it another try.

(Alf Gaida) #4

Right now we discussing some possible solutions:

  • I addded some WMs to our detection list (approx. 80), so the dialog should only show up if no WM is found
  • The solution could be just to take the first found WM as default if there is no preconfigured WM or the preconfigured WM is not available

(Jim Shriner) #5

Both of those are good ideas (are there really 80 different WMs?! Wow!), but taking the perspective of the layman user who doesn’t know any better, this might prevent the user from using the WM they prefer, thinking that it’s not available.

So I think your solution is a good one in that it forces a WM selection, even if it isn’t the desired one. The only con I can think of is that it might trick the user into thinking their preferred WM isn’t available. I’m still wondering if a “hint” to the user “if your preferred WM isn’t listed, go to usr/bin and select it” wouldn’t be helpful for the remaining user-case scenarios. If not right in the GUI dialog, perhaps a mouseover hint or something similar?

But I think your proposed solution will probably address the overwhelming majority of user scenarios. Certainly would’ve prevented Bog’s bad experience. JMO…

(Alf Gaida) #6

@hedon - i really don’t care. :sunglasses: - to be honest, i put all WMs available in Debian into this list. If the user have a WM installed that is not in this list, one can choose “Other” and search for the matching WM on his own. Problem solved. If it is a new WM we accept patches to extend the list.

Background to this issue:

(Alf Gaida) #7

Answer two: Hell, which user install a second Desktop Environment over an already configured and fine tuned environment - a no-go. I know that this is a big hobby in Ubuntu and other distributions. But it is the worst idea one can have. I see such installations inspired by Mary Shelly far to often in the past years, there is a word in debian for it: Frankendebian (meaning, taking parts from external repos or mixing Environments).


@agaida Well I didn’t “choose it to start”, at least no actively; not a conscious choice. There obviously was a problem “choosing the mate session”, like I said. It gave no option because I had chosen MATE it to go directly into my account at startup.

@hedon Yea the metaphor for learning something new is like saying I should learn how to drive a car with a flat tire. However, the rest of what you said makes sense- I’ll flesh out my suggestions for variations:

The “hint” idea is good- not only is it easy to implement, but also because that window is small and has plenty of room if you just make it 200 pixels wider, so plenty of explanation.

Also what might be good is, next to the “Go” button (and I know regular users wouldn’t know what to do, but if someone had been actively using their MATE environment for a couple months, they might’ve had data there that they worked on like last night that wasn’t backed up yet.), you can add a button to drop in to a CLI prompt. In other words- it does the same thing I did when I pressed alt-f4. (Which I imagine would also be easy to implement.) That way they could at least scp some files out if they were a little beyond novice enough to know how to do that.

Me, for example, I knew to do that, and if I hadn’t only just installed MATE then there might be something in there that I’d worry enough about to scp to the dev server. (Or, hell, to git commit something).

@agaida Yea the auto searching makes sense- you could add to that code a “preferred” list- a list that you all know is a “safe” one for lxqt, you know what I mean?

And you could combine that with my suggestion now about @hedon’s point of how does one “suggest” to the user how about this:

The list is a select box- you could automatically have one of the “safe” ones selected, and in the text above (which, again, there’s lots of room to add) you could say “here is a suggestion, but if you’d prefer your own, click the “Other” button”, blah, blah, etc.

(Alf Gaida) #9

@Bog: Did you really read the linked PR and Issue? Really?

And i guess that Mate use lightdm - one can select the session top right.


Yea, I did; it’s saying openbox sucks for lxqt, right? It looks like some of the responses say they can use it… I mean the text in the window could inclode that warning, and at least give the user the chance to logout and switch window managers, right?

@agaida er… I looked all over the screen for a way out. (be cause I didn’t want to have to reinstall MATE)

(Alf Gaida) #11

Autologin? Just in case - not really our problem.


Hahaaahahaa yea, ok, a defeatist attitude. BTW I posted the same post over at the MATE forums, I’ll update them on the response I got here.

(Alf Gaida) #13

Just do what you want to do - and i’m dead serious about. Damn, even as Ubuntu user try to learn a bit about the things you use. If the first thing you see is the WM dialog with no login before - my bad, it’s called autologin. In case there is a login screen before - well, one should be able to find the session switcher. Please be so kind and post this to the Mate forums too - maybe they can help you after they stop the laughter.

@tsujan - nice, isn’t it? First day of a new year …

(Alf Gaida) #14

and choose the session

And please don’t fool around with developers, they might bite.


Haha yea, well as a developer myself for 20 years, I rarely bite, but you’re correct sometimes we do!

Like I said- I chose autologin- so I didn’t get that prompt. It was going directly into your poorly designed dead-end lxqt window. When I had to reinstall MATE, I obviously chose to get a prompt, but I also obviously didn’t want to risk anything by installing lxqt, since I got burned by it rendering my computer unusable (unless I’m a WM developer).

(I say “dead-end” meaning that if you’re not knowledgeable about WM’s and for that matter where they live, then it’s a dead end.)

I should point this out- as I said, I’ve been a developer using linux (and in the old days AIX, and in the old old old days IRIX haha!) for 20 years, and I knew the basic idea of what a WM is, but I rarely had to use one until recently. Most of my linux skillzzz are server-side; so, CLI. (Previously know as “runlevel 3” as opposed to 5, right.)

A few years ago I actually ran ubuntu 16.04 (unity, unfortinately) and stuck with it about 2 years as my main workstation, until the drive crashed so I had to switch back to the windows 10 drive. Finally 6 months later I’ve gotten around to trying to switch back to ubuntu, here I am.

But my point is, at no time did I need to know where WM’s live. So even experienced developers don’t necessarily know much (or until now; needed to know) about WM’s. Two years, never needed to know.

(Alf Gaida) #16

nope - not our fault - as a developer you should be able to navigate to /usr/bin/openbox - and all things are fine. BTW - you use a far outdated version of LXQt. The culprit is here that ubuntu modify some pathes in /etc/X11/foo - that means that /usr/share/lxqt/session.conf is not loaded (nor any other LXQt setting), lubuntu LXQt branding not installed, because not available, to old version - meanwhile (we are about to release LXQt 0.14) some things has changed. lxqt-session (0.13) in ubuntu override some of the ubuntu specific things and load the defaults afaik.

So your best bet is to start into RL 3 or just open a virtual console and remove the autologin thingy from /etc/lightdm/foo - afterwards restart the DM and the login screen should appear.

And btw - i had to work with sinix, hp-ux, aix, os/400 for some years mostly in c/s-environments - in the beginning with serial attached dumb terminals.


Like I said from the op post, it’s too late now, I had to reinstall mate, I’m not going to try lxqt again- not just because it screwed me over but because of the “not our problem” “nope - not our fault” attitude, if that’s representative of the other developers too.

(Btw when you were using old serial attached dumb terminals were you using a WM? (that’s a sarcastic question) )

(Alf Gaida) #18

Thats damn easy - Windows was invented times ago - and one product our company sold was n.e.t.z termemu. Btw, X11 and window managers was around even 30 years ago, so it’s not that unusual. Still hate my sold sun station.


Kindergarten? Let’s summarize:

  • You’re a developer that claims 20 years experience
  • running an out-of-date version, of beta software (v 0.*)
  • that you’ve obtained completely free
  • installed it on top of an existing desktop
  • found a LXQt prompt, which was designed to be there, helping you select your VM

Finally you came here, to waste everyone’s time, even though Google would probably give you a billion results, explaining what this is, why you got it, and how to fix it – and even though you’re behaving like an idiot, people are still trying to help out.

(Pedram Pourang) #20

Then, it’ll be more rational if you stop wasting your time – and consequently, others’ time – here.