(Pedram Pourang) #21

In BreezeEnhanced, I easily separated KWin font settings from KDE’s. I think most of these dependencies aren’t necessary.

(Shrinivas Kumbhar) #22

i found a way to use kwin settings without installing plasma-workspace

what i did was to copy only lib file

/usr/lib/libkworkspace5.so from existing kde install to lxqt install

kcmshell5 only needs this file. not whole plasma-workspace

so kwin settings can be used by only installing kde-cli-tools.

no need to install plasma-workspace.

this saves 125 mb of installed packages and 32 extra unnecessary dependencies from tainting lxqt install

(Pedram Pourang) #23

Yes, if I recall correctly, I’d tried something like that in a machine without full KDE installation.

It’s sometimes amazing how a DE’s components can be used inside another. For example, LXQt’s platform integration (setting QT_QPA_PLATFORMTHEME to lxqt and QT_STYLE_OVERRIDE to kvantum) can be used almost everywhere — the only exception I’ve found is Plasma but it can be used in KDE too with other apps. Or lxqt-policykit-agent can be used inside Enlightenment; etc.

(Shrinivas Kumbhar) #24

so when used only kwin i got open/save dialog to be in fusion theme so i did this in ~/.profile i added

export QT_STYLE_OVERRIDE=kvantum

so should i Change QT_QPA_PLATFORMTHEME=lxqt

(Pedram Pourang) #25

QT_QPA_PLATFORMTHEME sets Qt platform integration and the best choice for it is lxqt. However, LXQt does it for you — you shouldn’t need to export QT_QPA_PLATFORMTHEME or QT_STYLE_OVERRIDE in ~/.profile when you use LXQt (Kvantum can be chosen in LXQt Appearance).

(Shrinivas Kumbhar) #26

but what happened was everything else was in kvantum style and only open/save dialog was in fusion it looked out of sort and editing profile solved it.

(Pedram Pourang) #27

That was because of QT_STYLE_OVERRIDE (although I don’t know which Qt platform integration you had used – qt5ct?). Let me explain it a little:

Since Qt5, Qt needs to be integrated into the current platform for it to use more advanced features of that platform. To do that, a DE should have a plugin – KDE and LXQt do. When QT_QPA_PLATFORMTHEME is set to lxqt (automatically done by LXQt if you have a complete LXQt installation), LXQt’s plugin will be used. LXQt’s file dialog is only a part of the integration.

(Shrinivas Kumbhar) #28

i am not using qt5ct i am using lxqt while before when i had plasma-workspace installed kvantum was set everywhere but now when i used only kwin without it. this thing happened. so what was at fault???

something is off now i removed .profile but kvantum is set to open/save dialog.

(Pedram Pourang) #29

plasma-workspace can’t affect LXQt. This line in your ~/.profile is wrong:


Try this (it’s safe):

  • Comment out those lines in ~/.profile;
  • Log out and log in again.
  • If the Qt style isn’t Kvantum, choose it from LXQt Appearance (and, preferably, log out and in again).

(Shrinivas Kumbhar) #30

after commenting that out kvantum style is used not fusion but dont know why previously fusion was used.

(Pedram Pourang) #31

Because of export QT_QPA_PLATFORMTHEME=kvantum – Kvantum isn’t a Qt platform plugin but a Qt style plugin.

(Pedram Pourang) #32

One other thing:

When a DE doesn’t have a Qt platform plugin, people usually install qt5ct. But if they install lxqt-qtplugin, libfm-qt and lxqt-config, they’ll have better choices.

Most DEs have GUIs for setting EVs, so that there’s no need to do it in ~/.profile. For example, I logged into Enlightenment now. I’d set QT_QPA_PLATFORMTHEME to lxqt and QT_STYLE_OVERRIDE to kvantum in its GUI before. So, I have LXQt’s file dialog inside E:

(Shrinivas Kumbhar) #33

@tsujan Is it possible to move .config/kvantum/kvantum.kvconfig

To .config/kvantumrc

So that it can be used in kde look and feel package to change kvantum theme.

Consider it as a feature request.

(Pedram Pourang) #34

No, it’s neither possible nor correct. KDE started to make a mess inside ~/.config since its version 5, as if it owned ~/.config. The config files of app X are inside the directory ~/.config/X. That’s how Qt works.

Also see https://github.com/tsujan/Kvantum/issues/411