Losing everything at shutdown


(Daniel Hollis) #1

Hello,

When shutting down or logging out of Lubuntu on my PC that I have installed and dual boot with windows 10, I get an LXQT system shutdown message that says: All unsaved work will be lost…

I set up some things last night and when I went in this morning everything was fresh brand new and things I installed were gone. How can I save everything so that I can log out or shut down and save my changes? Is there a way to set it up automatically?

screenshot


(stefano) #2

This refers to all kind of unsaved changes to documents (but for example Libreoffice will restore it usually). So just save them and close those programs. There is no feature that will close programs gently. But

this makes no sense, can you explain more what happened? Any installed application is always “saved” so to say.


(Pedram Pourang) #3

@stefonarch put it best, especially about “things I installed were gone”. I just add this:

That message is a warning that tells the most obvious thing: if a doc isn’t saved yet, the changes that are made to it will be lost. Some DE’s don’t give any warning on logging out/shutting down/rebooting; LXQt does. The dialog is there in case the user wants to change his/her decision and continue the current session.


(Daniel Hollis) #4

Well, I had added vs code and google chrome to lubuntu and added things to my quicklaunch bar and when I came back to lubuntu today after having computer off for the night, everything was back where I started. The computer, network, folders were on dektop even though I had removed them last time.


(Daniel Hollis) #5

Actually, I shut down and restarted and everything was saved this time.

One thing I have noticed is that about 50% of the time, the wifi connection shows an x and I need to reboot and it works fine. Any suggestions?


(Pedram Pourang) #6

Then a miracle happened. You could report it to Lubuntu by giving them a way of reproducing it.

Can have many reasons – bad connection is one of them – but none of them can be related to LXQt. A report at Lubuntu may not be a bad idea.


(Daniel Hollis) #7

Okay.

One more thing…

I click in chrome to make it default browser but I keep getting the same pop up to make it default. In LXQT there is dropdown for default but it only has firefox as an option. There is a browse buttone but where would chrome be located?

Thanks for your help.


(Pedram Pourang) #8

I can partly confirm this one on Debian Buster iso, installed on VirtualBox. Chromium does nothing when “Make default” is pressed in chrome://settings – that’s definitely an issue in Chromium – but when chromium is set in LXQt Session Settings → Environment → BROWSER, links are still opened by Firefox in any app (FeatherPad, for example) after logging out and in.

However:

(1) Cromium doen’t show any popup here. So, popups may be a problem that’s fixed in later versions of Chromium or by a patch.

(2) There’s no problem with Falkon: When I choose falkon for BROWSER in LXQt Session Setting, links are opened by Falkon as expected, not by Firefox.

So, I think Chromium has a problem.


(Daniel Hollis) #9

Interesting. Thanks. If I figure out a solution I will let you know.


(Pedram Pourang) #10

As a workaround for Chromium’s problem, the file ~/.config/mimeapps.list can be created (if it doesn’t exist) and these lines can be added to it:

[Default Applications]
x-scheme-handler/http=chromium.desktop
x-scheme-handler/https=chromium.desktop

Then, they will override BROWSER too.

I think Chromium created them in ~/.local/share/applications/mimeapps.list before but that file is deprecated and Chromium hasn’t updated its method — just a guess.

Anyhow, I think LXQt should automate this procedure – users shouldn’t need to edit such files manually and Chromium’s issue doesn’t justify the above-mentioned situation.

@agaida, any idea?


(Daniel Hollis) #11

I also went into file associations for lxqt and under html, I changed to chrome. Now links are opening in chrome.


(Pedram Pourang) #12

That’s for file association, which can also be done by right clicking an html file.

I was talking about a GUI for associating x-scheme-handler/http, x-scheme-handler/https and x-scheme-handler/mailto, at least. They are for opening links (like https://forum.lxqt.org) inside apps, not for opening files.

I always edit mimeapps.list manually; so, I admit that I may be missing something here.