LXqt and Bluetooth

(Дмитрий) #1

Good day, tell me how to start Bluetooth in LXQt? my experience of using Linux is very small, sorry if the question turns out to be stupid. LXQt works very fast it’s cool

(Pedram Pourang) #2

Install and run blueman.

(Shrinivas Kumbhar) #3

or blueberry or bluedevil (to use bluedevil just go to /usr/share/applications search bluedevil.desktop file then edit it. and remove the line only show in = kde )

(Shrinivas Kumbhar) #4

although lxqt is fast but not as fast as wayland compositer.like sway or wayfire. lxqt is slow compared to them. even with openbox as wm

(Pedram Pourang) #5

LXQt isn’t a compositor and doesn’t (won’t) have a compositor of its own. A compositor may be slower/faster than the other. And wayland still has serious problems.

Anyhow, what’s the relation to bluetooth?

(Pedram Pourang) #6

BTW, you mentioned Sway. I can’t imagine that someday, I’d have to use something as elementary as Sway — that would be an awful regression to me, after using Linux for more than 14 years. Even the first version of Gnome2/KDE3 I used was more functional than Sway is :wink:

(Дмитрий) #7

installed blueman, when you start it usually warns that Bluetooth is off, although in the network settings it is displayed as enabled, OK click enable in the dialog box with blueman, but he does not see the module(( (the module is 100% working, I use it when I play games on Windows) screen1 screen2

(Pedram Pourang) #8

Forget about CMST in this regard. Just do as blueman says and you could use Bluetooth without problem.

(Дмитрий) #9

if you have information on installing and replacing it in lxqt I will gladly read it

(Дмитрий) #10

blueman says no adapters found

(Pedram Pourang) #11

Make sure you’ve installed all of its Recommends/Optional Dependencies (depending on your distro).

(Pedram Pourang) #12

Also bluetoothd – belonging to bluez or whatever its name is in your distro – should be running.

(Дмитрий) #13

installed 2 packages bluez-firmware and bluez-tools, adapter not found…

and how to check that it works? in the network settings I turned on Bluetooth

(Pedram Pourang) #14

I tested right now and encountered no issue. The problem may be in blueman or python your distro provides. Here, blueman’s version is 2.1.1.

(Дмитрий) #15

:~$ systemctl status bluetooth.service ● bluetooth.service - Bluetooth service Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled) Active: active (running) since Wed 2019-12-04 17:24:58 +05; 1h 14min ago Docs: man:bluetoothd(8) Main PID: 601 (bluetoothd) Status: “Running” Tasks: 1 (limit: 4915) Memory: 3.1M CGroup: /system.slice/bluetooth.service └─601 /usr/lib/bluetooth/bluetoothd

this? p.s not found how to insert code

(Pedram Pourang) #16

Yes. It’s running for you.

I suspect blueman+python in your distro. Here, blueman has always been reliable.

As the last resort, you could test this:

  1. Exit blueman.
  2. Turn off Bluetooth in CMST (what you called "network settings ").
  3. Reboot.
  4. Don’t change anything in CMST and run blueman from the main menu.

Even if it works, something is still wrong because it should have worked from start.

(Дмитрий) #17

I found information that the Bluetooth module cannot start in Linux

hciconfig hci0: Type: Primary Bus: USB BD Address: 00:1A:7D:DA:71:11 ACL MTU: 679:9 SCO MTU: 48:16 DOWN RX bytes:1148 acl:0 sco:0 events:60 errors:0 TX bytes:736 acl:0 sco:0 commands:60 errors:0

sudo hciconfig hci0 up Can’t init device hci0: Operation not supported (95)

(Shrinivas Kumbhar) #18

its completely out of topic i know but yeah i also dont use sway. but i am using wayfire. i also made an iso of wayfire to have preconfigured environment

(Pedram Pourang) #19

I might test it. Thanks for the link!

So far, the “best” and most advanced Wayland compositor I’ve seen has been KWin. Enlightenment has the second place. The problem is that no wayland compositor supports selection clipboard or follows window positioning in codes. These are really elementary things. With wayland, when you open a menu, it might appear at the far side of the screen. Ridiculous! A simple drag-and-drop can cause crash. Silly!

Let’s not go off-topic here.

(Alf Gaida) #20

@tsujan - please try my latest gnome build :smiley:

Edit: With the su/sudo thing integrated is would tend to like kwin more :smiley: