LXqt and Bluetooth


(Shrinivas Kumbhar) #21

well i have never experienced these problems that you mention with wayfire. i can definitely say its way better than kwin.

though if you test, dont test in in a vm.you may not get a video output. test on bare metal.


(Pedram Pourang) #22

@agaida I have Gnome with Wayland on another computer. Not impressed. And I’d tried that ISO.

@librewish I tried the wayfire ISO just now: I AM IMPRESSED. However, Qt is terrible with it: no Qt menu can be opened.

I was also impressed by seeing Kvantum Manager among the apps. Qt menus didn’t open, whether with Kvantum or with Fusion.

Now, my list is so: 1. KWin. 2. Enlightenment. 3. Wayfire. Of course, I mean it with Qt apps; otherwise, Wayfire has been the best with GTK,


(Shrinivas Kumbhar) #23

what kind of qt menus? i never noticed this. everything just works fine.


(Pedram Pourang) #24

Any Qt menu, right-click or just menu-bar menus. Here, Qt isn’t usable with Wayfire but that may be a Qt issue. Let’s hope it’ll be fixed soon – in Qt or Wayfire.

I have Intel.


(Shrinivas Kumbhar) #25

well i can open right click menu and menubar menu. from qbittorent app just fine


(Pedram Pourang) #26

A compositor should work everywhere – at least with Intel. On the same computer, an old version of Wayland KWin doesn’t have any problem with Qt menus. It also has a nice blurring effect (IMO, translucency doesn’t make sense without blurring).

The problems with Qt menus under Kwin appeared recently. I can see them with my work laptop, which has the latest version. I think KDE developers are doing some trial-and-error…


(Дмитрий) #27

cannot find a solution for hciconfig hci0 up Can’t init device hci0: Operation not supported (95)


(Shrinivas Kumbhar) #28

here the menus ope just fine intel


(Pedram Pourang) #29

When you don’t say which versions of blueman and python and which distro, I don’t think anyone can help you. You need to have blueman 2.1


(Pedram Pourang) #30

I believed you when you said they can be opened there. Believe me when I say they can’t here :wink:


(Shrinivas Kumbhar) #31

did you enable Bluetooth in cmst ? otherwise Bluetooth wont work


(Дмитрий) #32

blueman 2.0.8-1 python 3.7.3


(Дмитрий) #33

hw-probe https://linux-hardware.org/?probe=0eb25514ee


(Pedram Pourang) #34

Good enough. I have no clue.


(Дмитрий) #35

hcitool dev Devices:

sudo hciconfig -a hci0: Type: Primary Bus: USB BD Address: 00:1A:7D:DA:71:11 ACL MTU: 679:9 SCO MTU: 48:16 DOWN RX bytes:1722 acl:0 sco:0 events:90 errors:0 TX bytes:1104 acl:0 sco:0 commands:90 errors:0 Features: 0xff 0xff 0xcd 0xfa 0xdb 0xbf 0x7b 0x87 Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 Link policy: RSWITCH HOLD SNIFF PARK Link mode: SLAVE ACCEPT


(Alf Gaida) #36

But i have a problem here: It all was a big waste of time - and if i would not have read the hardware thing i still would not know which OS is used. And this should not the way the things work here. In github this report would be long closed and done.


(Pedram Pourang) #37

@librewish

I investigated Wayfire ISO’s Qt problems. To see one kind of it, run this and take a look at toolbar buttons:

qbittorrent -style fusion

They are related to neither Wayfire nor Qt but only Qt5ct. Qt5ct is the worst Qt plugin. Use lxqt-qtplugin instead, although you’ll also need some other LXQt component for configuration.


(Pedram Pourang) #38

At least, I tried Wayfire :wink:


(Alf Gaida) #39

ok - solve no bluetooth problem (ok, the chip is around since 2007/2008) and is known to work. So the basic questions would be:

  • what does rfkill say?
  • is there any firmway to be enabled (non-free?)
  • what says google about?

So regarding bluetooth - nothing we should do here, linux is hard in that regard - and i just tested it on my new laptop - this cheap one was so hard that i asked our kernel guy to patch the missed hw parts in :smiley:


(Pedram Pourang) #40

My experience with Linux+Bluetooth with 2 desktop computers and 2 laptops: it has always worked like a charm. Maybe, I’m lucky :wink: