LXQt function has vanished


#1

I’m using LXQt on Arch Linux with an OpenBox session. Recently I went into openbox to do some tweaking. On returning to LXQt it has gone haywire. I wonder if anyone has ever encountered this and what to do about it.

  1. Logout doesn’t work, though shutdown and restart do.
  2. Any settings made in the LXQt configuration center, such as icon changes don’t take.
  3. The application menu was reset to Lxde. This I could easily change to LXQt. I have tried reinstalling LXQt with pacman -S lxqt, but no change. Applications don’t seem to be effected. Is LXQt this delicate? I realize that it may share some files with openbox and that changing, for example, the openbox theme in openbox might effect how it was set within LXQt, but I no longer have a functioning desktop. Would appreciate anyone’s experience or knowledge.

(Ivan M.) #2

Maybe useless but you can set the application menu by left clicking over app menu icon and then ->settings. I have no clue about the other issues.


(Pedram Pourang) #3

Definitely not.

Your description is so general and unusual (especially when you say, “The application menu was reset to Lxde”) that I don’t think anyone could help you but let’s hope that I’m wrong. Perhaps, you don’t install any optional dependency, or…


#4

Yes, I hope someone can help. I like LXQt and want to keep using it. And, yes, I hope it’s not so delicate. And it’s unfortunate the unusual cases are sometimes hard to fix. The application menu reset was easy to fix. But why should it happen? That is the important question for which I need answers, as I’m setting up a Linux system for someone else who’s not so Linux savvy and I want it just to work. This computer is a NUC6CAYH running Arch Linux.
Here is what happened: LXQt has been working like a charm since I installed this system a few days ago. I installed openbox both as a window manager for LXQt and an alternative DE in case something went wrong with LXQt (and it looks like I may have to use it). All I can say is all applications are working well, but LXQt control panel functionality is gone. For example, if I attempt to set the desktop background image as I had it before, LXQt makes no fuss. No error messages. But the background image is not set. It’s the same if I try to set an icon style. The icons in the LXQt configuration center have generally gone missing. Only text is there. But icons for the rest of the system are working as before.
So if I had to guess something specific, I’d say that the LXQt configuration center functionality has disappeared, as far as making any settings. Also, the logout menu doesn’t work, as I mentioned before. The DE itself is functioning except for that.
I have attempted a reinstall but that didn’t help. What I might like to try is removing parts of LXQt and then reinstalling to be sure of fresh files, but I don’t know which parts to remove or how.
I have tried tinkering with openbox with LXQt installed on another computer, a Chuwi laptop, running ArcoLinux. I set openbox to use the LXQt panel within Openbox, and worked fine, but going back to LXQt there were some issues, but only with the panel. Just want you to know I love LXQt and hope this can make it better. From replies it seems maybe no one has tried to get both Openbox and LXQt both fully functioning at the same time. Help appreciated. Kendew


(Pedram Pourang) #5

You may not be inside an LXQt session at all. (Check it with echo $XDG_CURRENT_DESKTOP)


#6

You are right! I created such a nice LXQt-like Openbox environment that it fooled me. Don’t know how I got there as I was sure I was logging back into LXQt. Not very happy about how frazzled my brain must be to miss the obvious, but am very, very relieved there was never anything wrong with my favorite DE!


(Alf Gaida) #7

Sounds like a lxde session …