LXQt over Xrdp


(Timjaknz) #1

I’m trying to run LXQt over Xrdp (Ubuntu 18.04) using Openbox. It sort of works but I can’t run anything that requires elevated priviledges (like a software update). I assume it’s probably related to the polkit problems others have experienced, but none of the solutions for that work. Any suggestions?


(Alf Gaida) #2

Which polkit problems? Second question: LXQt don’t provide any components for upgrades etc - so a good configured sudo or policykit might help. I suggest to ask in some ubuntu channels about.


(Timjaknz) #3

The polkit problems talked about (with solutions) here. OK yes it looks like I’ll need some polkit rules relating to how LXQt handles implicit authorisations. I have also asked in ubuntu forums so will see what comes of that. Working out the polkit rules required for LXQt could be a bit trickier.


(Alf Gaida) #4

ok - never ever used LXQt on an Ubuntu host - my setup is LXQt on rockstor via xrdp - and to be honest: i never cared about things like networking or updates, i just used the systems settings - an i’m root, so su - is sufficient.

Btw: this is a point i would think about again - installing packages or running updates on a remote machine is an admin job. So it is fine just to use su - - i know that ubuntu users don’t know su, maybe you should learn about. It will be hard, i was nearly banned in the german ubuntuusers forum ten years ago because of asking about su and why sudo su and sudo passwd are bad things, but it might be worth the pain (One of the many reasons i prefer linux over an open source software operating system that runs from the desktop, to the cloud, to all your internet connected things)


(Alf Gaida) #5

Thinking about it again - yes, i really would use ‘su -’ - and i would explicitly forbid some things that are currently allowed via polkit rules. Thinking especially about ‘lxqt-leave --reboot’, ‘lxqt-leave --shutdown’ or un-/mounting devices and some other admin jobs that will be very risky on remote machines.

@tsujan @palinek - we should keep this one in mind and talk about


(Timjaknz) #6

I do mostly use an ssh terminal remotely so I am pretty familiar with using sudo and su. Sometimes it’s just easier to do installs, run updates / file moves /copies, use gparted etc. from a gui environment.
btw what window manager do you use with your setup? Also not having access to LXQt-leave etc. isn’t an issue right now because my leave menu shows nothing anyway - another little problem I haven’t gotten to the bottom of yet (even after editing /usr/share/applications/lxqt .desktop options).


(Alf Gaida) #7

Hmm - sounds strange - could you list your lxqt-package?

dpkg -l lxqt-*

I use xfwm4 on the rockstor based installation with xrdp - in my daily used installations i constantly switch between kwin and xfwm4.


(Timjaknz) #8

I build lxqt from the latest version from Git. So running dpkg gives the attached result.

I had a look at polkit but it’s tricky to determine the action.id to determine the correct rules. Especially as I have version 0.105 so no javascript based rules files (or logging). I tried building a later version of polkit but that was a bit of rabbit-hole.


(Alf Gaida) #9

if you built yourself - please make sure that the packages have a higher version than the packages in archive (all packages) - and please build "all the things"™ according to the build order. Otherwise it don’t make any sense. Maybe we should talk about in OFTC #debian-lxqt, #lxqt or #lxq-dev.


(Timjaknz) #10

OK thanks. I’ll remove everything and then run back through the build process again and see how I get on. Cheers


(Alf Gaida) #11

To be honest - i would have a look into salsa.debian.org - you will find the source package names and have a closer look into the experimental snapshot branch. the packaging should work™ fine with a current ubuntu. to get the current sources use the current debian lxqt-built-tools and git snapshot - done. One might configure/change the tools, esp the upload things to his/her needs. Suggestions welcome.


(Timjaknz) #12

OK thanks that seems to have worked. Now the leave menu works correctly.
Only problem now is that once I logoff I cannot start a new session. I can reconnect if I don’t log off the session but as soon as I logoff that’s it until I reboot. I’m guessing though that is maybe more to do with Xrdp and Openbox than LXQt.


(Alf Gaida) #13

i encountered some problems with the session manager too - but that was under rockstor (yes, i misuse a NAS System :slight_smile:)