LXQt panel appearing with huge delay when home directory moved


(stefano) #1

I’ve a LXQt Debian Buster pretty recent installation.

I just added a ZFS mirrored pool and wanted to move home directories there. I’ve already tried with two of the three users with the command: # usermod -d /zp1/home/username -m username

What is happening is that despite in terms of functionalities everythig seems working as normal, the main panel (with application menu, application bars, clock, etc) is appearing many seconds after the sddm login (maybe 30).

The desktop is instead appearing normally and is working (e.g. open directories with PCManFM-Qt).

Some suggestion to resolve the problem?

Thank you! _Stefano


(Pedram Pourang) #2

This is just a simple suggestion and may not work (I don’t know the cause of the delay you see) but is worth a try:

Stop the panel from session settings, rename ~/.config/lxqt/panel.conf and start the panel again.


(Pedram Pourang) #3

If that doesn’t work:

Are all optional dependencies/recommended packages installed? libpulse, libstatgrab, libsysstat and lm_sensors or whatever their names are in your distro.


(stefano) #4

I was logged on with my user and renamed the panel of one of the two other users (in panel2.conf). Nothing changed, meaning all still working but with this enormous delay in opening.

A new note: at the login of the “wrong” users the disk with the home directories start running crazily (as it was looking for something through all of it).

Regarding the packages seems the name in Debian are different, but anyway my other user still works fine and both of these “wrong” ones were working fine before the move!..


(stefano) #5

I did some more investigation and seems that the problem is related to ZFS filesystem (or some properties I setup e.g. atime=off or xattr=sa), since the problem is not presenting moving back to the previous drive but to a different directory (home2), while was there moving to a different directory on ZFS…


(Pedram Pourang) #6

It’s good to add noatime to fstab but I don’t know about ZFS.

The cause of the delay is still a mystery…


(Alf Gaida) #7

I did some investigations too - and it isn’t a zfs issue.

The issue is the statusnotifier plugin - just remove it from the panel and test again. If it works please file a bug against debian lxqt-panel


(Alf Gaida) #8

Found it - just install sni-qt

apt install sni-qt

and be done with.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=928524


(Pedram Pourang) #9

Who uses Qt4 anymore?!

The answer is, “I do but only one app and without systray.”

So, the mystery is really solved?


(Alf Gaida) #10

just tested it myself with a newly installed debian system - and yes there are some components installed that are still Qt4 - Qt4 removal is hopefully directly after the release of Buster, until then we have to struggle with it. And the problem really sucks (or better: gives not the best user experiance and let us look like utter idiots)


(Pedram Pourang) #11

So, the real problem was the bad relationship between Qt4 and the new system tray. Who could predict that?


(Alf Gaida) #12

The packager - i introduced sni-qt years ago in siduction - so i never ever noticed any problem. I leaved it in my package list for the sake of completeness :smiley:


(Pedram Pourang) #13

I have it too because I forgot about it. Octopi shows a green skull beside it :wink:


(Alf Gaida) #14

sni-qt wasn’t the solution - so, out of ideas right now


(stefano) #15

I’ll be able to do tests again next weekend back home. I’ll try anyway all the suggestions and let you know. Thank you for support in the meantime!


(Pedram Pourang) #16

Ha ha… mystery returns.


(Alf Gaida) #17

isn’t that funny :smiley: - and i’m a bit limited here, on my deadly cheap 17" laptop (Pentium Siver + intel 630 graphics) it work without any delay. Will now test my ancient (2009) Studio 17 with P9800 and AMD Graphics - My workstation is the only one with nvidia graphics - only in case that graphics do matter.

It might be too that the delay is somewhat related to filesystem things - and in this case it would be the culprit, the laptops only have one or two SSD, my Workstation has some SSDs, 2 bigger normal HDs in a soft raid and with some LVM things on it.

The only thing what bother me is: Hell, my siduction installation is fast, debian not - and it should have the same packages. Will try with a new installation of a standard Siduction unstable, only the kernels should differ a bit.


(Alf Gaida) #18

@tsujan - it becomes far more worse: Installed a fresh siduction (same LXQt packages as in debian (same repo) - Siuction don’t have the lag, debian has. And i can’t swear about the morons who maintain the packages … :frowning:


(Pedram Pourang) #19

If only you describe a simple way of reproducing it so that I can see it here without hassle and, especially, without changing my partitions. In all years that I’ve used LXQt, I’ve never seen a delay at login.


(Alf Gaida) #20

Download the latest debian testing lxqt iso non-free, create a partition for it - start and install with calamares. Reboot.

The nice thing about is that the lag seems to depend on the used machine. My workstation: Laggy and reproducible laggy. The cheap notebook is fast - ok, next notebook :smiley: