LXQt panel appearing with huge delay when home directory moved


(Pedram Pourang) #21

A link, please!

I’ll do it tomorrow if I find no time tonight (on VirtualBox).


(Alf Gaida) #22

https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/weekly-live-builds/amd64/iso-hybrid/

https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/weekly-live-builds/amd64/iso-hybrid/debian-live-testing-amd64-lxqt+nonfree.iso

Specs of machines without lag:

  • Lenovo Flex 2-14
$ sudo inxi -SMCGDI
System:
  Host: buster-lxqt Kernel: 4.19.0-4-amd64 x86_64 bits: 64 
  Desktop: LXQt 0.14.1 Distro: Debian GNU/Linux buster/sid 
Machine:
  Type: Laptop System: LENOVO product: 20404 v: Lenovo Flex 2-14 
  serial: WB15365140WB0409170M 
  Mobo: LENOVO model: Lenovo Flex 2-14 serial: WB15365140 UEFI: LENOVO 
  v: A0CN27WW date: 07/29/2014 
CPU:
  Topology: Dual Core model: Intel Pentium 3558U bits: 64 type: MCP 
  L2 cache: 2048 KiB 
  Speed: 898 MHz min/max: 800/1700 MHz Core speeds (MHz): 1: 898 2: 898 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel 
  Display: server: X.Org 1.20.3 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.3.4 
Drives:
  Local Storage: total: 494.40 GiB used: 8.96 GiB (1.8%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Ultra size: 28.64 GiB 
Info:
  Processes: 138 Uptime: 20m Memory: 3.76 GiB used: 1009.2 MiB (26.2%) 
  Shell: bash inxi: 3.0.32 

  • HP 17-by0
$ sudo inxi -SMCGDI
System:    Host: buster Kernel: 4.19.0-4-amd64 x86_64 bits: 64 Desktop: LXQt 0.14.1 
           Distro: Debian GNU/Linux buster/sid 
Machine:   Type: Laptop System: HP product: HP Laptop 17-by0xxx v: Type1ProductConfigId 
           serial: 5CG822735H 
           Mobo: HP model: 84CE v: KBC Version 89.18 serial: PHHPC00WBAW0ZS UEFI: Insyde v: F.05 
           date: 04/09/2018 
CPU:       Topology: Quad Core model: Intel Pentium Silver N5000 bits: 64 type: MCP 
           L2 cache: 4096 KiB 
           Speed: 796 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 794 2: 796 3: 796 4: 796 
Graphics:  Device-1: Intel UHD Graphics 605 driver: i915 v: kernel 
           Display: server: X.Org 1.20.3 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 605 (Geminilake) v: 4.5 Mesa 18.3.4 
Drives:    Local Storage: total: 931.51 GiB used: 9.00 GiB (1.0%) 
           ID-1: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
Info:      Processes: 145 Uptime: 5m Memory: 7.58 GiB used: 744.7 MiB (9.6%) Shell: bash 
           inxi: 3.0.32 

Specs of machines with the mentioned lag

  • HP Studio 1737
$ sudo inxi -SMCGDI
System:                                                                                    
  Host: hp-buster-lxqt Kernel: 4.19.0-4-amd64 x86_64 bits: 64 Desktop: LXQt 0.14.1         
  Distro: Debian GNU/Linux buster/sid                                                      
Machine:                                                                                   
  Type: Portable System: Dell product: Studio 1737 v: A09 serial: ��q�?%�                  
  Mobo: Dell model: 0P786H v: A09 serial: .��q�?%�.CN486438B83903. BIOS: Dell v: A09       
  date: 04/14/2011                                                                         
CPU:                                                                                       
  Topology: Dual Core model: Intel Core2 Duo T9400 bits: 64 type: MCP                      
  L2 cache: 6144 KiB                                                                       
  Speed: 1596 MHz min/max: 800/2534 MHz Core speeds (MHz): 1: 965 2: 994                   
Graphics:                                                                                  
  Device-1: AMD RV635/M86 [Mobility Radeon HD 3650] driver: radeon v: kernel               
  Display: server: X.Org 1.20.3 driver: ati,radeon unloaded: fbdev,modesetting,vesa        
  resolution: 1920x1200~60Hz 
  OpenGL: renderer: AMD RV635 (DRM 2.50.0 / 4.19.0-4-amd64 LLVM 7.0.1) 
  v: 3.3 Mesa 18.3.4 
Drives:
  Local Storage: total: 931.51 GiB used: 9.01 GiB (1.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
Info:
  Processes: 149 Uptime: 7m Memory: 3.82 GiB used: 898.8 MiB (23.0%) Shell: bash 
  inxi: 3.0.32 

Findings:

  • removing the statusnotifier plugin remove the lag nearly completly on Studio 1737
  • removing mount and systray plugin == no delay on Studio 1737

(Alf Gaida) #23

The interesting question is - wtf this only on debian and not in siduction. Right now i really don’t know the difference.


(Pedram Pourang) #24

Read my story! It ends with good news.

I installed Buster on VirtualBox, having given 2 GiB of memory and 2 CPU cores to it. The installation took longer than I’d expected — on one occasion, I thought it hung and I wanted to close the virtual machine but it was finished successfully. Damn! After being away from Debian for 4 years, I saw that share-mime-info still took a long long time to complete its job on Debian (while it’s quick on Arch/Manjaro). Debian should really do something about that. Anyhow:

First, Debian’s LXQt support is excellent. It feels so light and fast. The boot is also unusually fast. I like how Panel is arranged. The software selection is great too. Very nice work!

Second, I saw Panel’s delay. It’s 30 seconds here. Once I removed Status Notifier from Panel, there was no delay anymore. Installation of sni-qt or removal of Systray had no effect. Starting Panel from terminal or Session Settings was fast (normal) with Status Notifier.

Third, after adding Status Notifier, I removed xscreensaver from startup and the panel showed up fast but it still took 30 sec. to be ready for use. I purged xscreensaver and the same delay happened. So, I got suspicious of xfwm4: reinstalled xscreensaver, installed openbox and enabled both. The delay disappeared completely :slight_smile:

Please note that I also purged fcitx and uim but the delay didn’t disappear after that.


(Walter Lapchynski) #25

Am I reading correctly that the problem is xfmw4???


(Pedram Pourang) #26

At least here, on VirtualBox, it’s definitely xfmw4. Panel starts super fast with OpenBox. There can be a conflict somewhere; xfmw4 may be innocent and just at one side of it.


(Walter Lapchynski) #27

I only ever use Debian for testing, so I usually just boot it and go do something else so I never noticed, but yeah, it looked like it was about 22 seconds. That’s insane.

To be frank, that reminds me of how LXDE used to be in Lubuntu. Now you log in and :exploding_head: there is your functional desktop. Every time I have to boot up an old version for support it makes me long for the days that LXQt is all we have to support.

Anyways, I digress. I booted Lubuntu 19.10, installed xfwm4, swapped window managers, logged out and back in and— wait for it— no delay.


(Pedram Pourang) #28

A conflict somewhere – that’s my theory.


(Alf Gaida) #29

Tried yesterday openbox on my main machine and had the same delay. so something is blocking in the panel plugins.

Thanks for the nice words about debian LXQt. A reason might be that i was a bit selfish when i created the meta packages - to be flexible and with sane defaults - as i wrote, two of my weakest machines don’t show any delay, my good old Studio shows, but should be par or ahead in terms of pure processing speed, but not in cores.

Right now i’m going back to the roots and install only a netinstall image without anything …


(Pedram Pourang) #30

Yes. @palinek may know what it is. Call him somehow!

I said that without any exaggeration. It’s brilliant.


(Alf Gaida) #31

but there are still many things to improve, keep in mind that the base is in no way optimized for LXQt - there are to much standard packages in the live iso that don’t fit well for LXQt - live iso’s are dead simple - just install the standard base and the lxqt metapackage - at least it should be that way.

PS: I’m nearly satisfied with, given the fact that i’ve done nothing about - ok, i test from time to time. But it is the first version :slight_smile:


(Pedram Pourang) #32

Any good thing can be improved. It’s really good and gives a very positive image of LXQt to users.

As for the delay, it may be related to dbus. Openbox or xfmw4, our Status Notifier shouldn’t cause a delay. Open an issue and assign @palinek; he knows these things very well.


(Alf Gaida) #33

fun fact - i build a siduction default LXQt - one of the differences is the current kernel - all other packages are from debian (ok, some settings, branding etc) - no delay.


(Walter Lapchynski) #34

WTF I tried to debug this and now I can’t reproduce it.


(Alf Gaida) #35

hihihi - had this yesterday too one time


(Pedram Pourang) #36

Heisenbug in Status Notifier :wink:


(Walter Lapchynski) #37

Shrödinger’s Cat! :crying_cat_face:


(Alf Gaida) #38

my problem right now is - i don’t have any spare SSDs - should buy a current one and remove some from my workstation. Just throw a spare 1T rotational into the Studio - and it’s feeling damn slow :smiley:


(Pedram Pourang) #39

I rebooted the virtual machine several times, also logged out and in, but couldn’t reproduce it with openbox. Tomorrow, I’ll try xfmw4 again but the bug exists in Status Notifier and should be fixed; xfmw4 was just a trigger here, IMO. Although, who knows…

Now, I should sleep; I’m very drowsy…


(Pedram Pourang) #40

I guess Debian doesn’t have this fix https://github.com/lxqt/libqtxdg/commit/7a0a262b4b9b8ec0ba5420b9eb1667c641083474

It talks about fixing a 25s delay. It may not be related but is worth a try.

Sleeping again, for 9 hours…