Network Manager?


(Giorgos) #1

Hi! :slight_smile:

Which Network Manager is recommended? I’m interested for connecting - disconnecting on the fly and setting custom DNS servers (Quad 9, Google DNS etc).

TIA! :slight_smile:


(stefano) #2

I’m happy with connman and cmst


(Pedram Pourang) #3

Like @stefonarch.

Years before I became an LXQt user, I left NetworkManager for connman (+CMST) and have never had any problem with any kind of connection under any DE or with any computer (3).

I remember that, on Debian, connman and NetworkManager packages had conflict with each other. On Arch-based systems, there’s no conflict but NetworkManager’s service(s) should be stopped and disabled.


(Alf Gaida) #4

I use network manager with nm-tray or gnome-nm-applet sometimes, but after an hour i switch back to connman and cmst in the very most cases :slight_smile:


(Giorgos) #5

THANKS guys!!! :wink:

I tried them all and indeed they are good.

I still have the problem with the custom nameservers. No matter what I enter, its ignored.

Something seems to be broken on distro level.

(I’m on a Debian based one). I’ll search for a way to enter the nameservers independently of the nm.

THANKS AGAIN for the suggestions!!! :wink: G.


(Alf Gaida) #6

@Giorgos - pls. excuse my ignorance - but what do custom nameservers have to do with networkmanagement? I don’t want provoke, but never encountered that in 9 years - maybe a hint:

apt purge resolvconf

might help, never understood the sense of the program - in case of using connman this package will be counterproductive too - connman does resolving configurations itself.


(Giorgos) #7

@agaida I was trying to replace my ISP’s DNS servers, with other (Quad 9, Google DNS you name it).

No matter what dns servers I’m entering they ignored.

  • I don’t have resolvconf installed any more (although I gave it a try).

#8

+1 for ConnMan and CMST! :slight_smile:

This combination has nearly the half size of NetworkManager and furthermore, it is free of bloatware. And the best thing: CMST is Qt… :wink:


(Alf Gaida) #9

Ok - only my very personal point of view - any network management sucks :sunglasses: On the siduction servers i use systemd-networkd - perfectly fine, once set up, never touched again. The same way i would do with my main workstation - but decided against and use connman and cmst - Reason: Eat your own dogfood, i should use the packages i maintain myself. On most of my many lxc containers i use whatever lxc suggests - containers are boring :smiley:

Most of the time i use connman and cmst on my laptop installations - reason above and it is default in LXQt, in any other Environment i use what ever the guys set as default :wink: - but connman getting better with every release.


(jwh) #10

I don’t use a GUI mgr, but maybe this will help you…

https://wiki.archlinux.org/index.php/Domain_name_resolution#Overwriting_of_/etc/resolv.conf

Or maybe there are some Debian-specific wiki’s too. :slight_smile:


(jwh) #11

Ya I use the systemd network/resolve/timesyncd stuff for the simplicity, and especially to save space on my old netbook with 4GB embedded SSD. :-\ Though it actually runs lxde for the same reason; I use lxqt on my x64 dev PC.


(Giorgos) #12

@jeremywh7 Actually I use resolve.conf. :slight_smile: My problem is that installing LXQt from repositories, although resolve.conf remains untouched, it just stopped having any effect and seems to be ignored. Probably a distro bug.


(Alf Gaida) #13

@Giorgos - don’t know what exactly you use, but - the handling of the resolv.conf file is a bit complicated. In case of connman it should look like this:

8915506 lrwxrwxrwx 1 root root 24 Jan  7  2017 /etc/resolv.conf -> /run/connman/resolv.conf

In case of n-m it should be:

# Generated by NetworkManager
nameserver 10.0.2.3

and so on - so if on a debian derivative please have a look at the running task - if you run two network management services and one take over it might be that the real resolv.conf is somewhere in /run.


(Giorgos) #14

Not able to solve the problem, I restore a system image and I started all over again.

This time, disabling DHCP and entering details manually worked with the exception of DNS servers.

Editing /run/connman/resolv.conf and replacing the default values with the proper ones, did the trick! :grin:

No hint what went bad at the first place, but Debian based distros (as mentioned above), has weakness on handling properly network managers.

THANKS AGAIN!!! G.


(Alf Gaida) #15

@Giorgos - a clear and fat NO! - debians weak points are the users some times. To be clear about: if connman handle Network Connections, just open CMST and set your dns servers. If connman don’t handle the Network connections:

su -
rm /etc/resolv.conf
echo nameserver xxx.xxx.xxx.xxx > /etc/resolv.conf

repeat the echo with additonal nameservers if needed. (Written with my DM hat on.)


(Giorgos) #16

/etc/resolv.conf here is only a link to /run/connman/resolv.conf.


(Alf Gaida) #17

that means that connman is installed - but it don’t mean explicitly that connman is the service that will win, esp. if more services like network-manager are installed. if only connman is installed and running the link to /run/… is ok. In that case i would suggest to use cmst or connmanctl in the terminal to set the DNS to use in the connman settings. Also important: connman will create the file in /run on every systemstart - /run should be mounted to tmpfs :slight_smile:

That was the reason for: “if not managed by connman … rm /etc/resolv.conf (the link)” an create a regular file.

https://www.debian.org/doc/debian-policy/ch-relationships.html#s-conflicts

Neither Breaks nor Conflicts should be used unless two packages cannot be  
installed at the same time or installing them both causes one of them to  
be broken or unusable. Having similar functionality or performing the same  
tasks as another package is not sufficient reason to declare Breaks or  
Conflicts with that package.

so one can co-install n-m, connman, wicd etc - but the user should be able to manage the mess then.


(Giorgos) #18

Well…since everything works as expected, I’ll just leave it as is, at least for the time being.