No action with print key


(Papoteur) #1

Hello, I have tried to configure the Print key to take screenshot. I have first installed screengrab. In config panel, I selected the Shortcuts. The entry 18 is about the Print key and I have altered the command with screengrab. However, this has no effect, even after a reboot. Nothing happens when I hit the key. What I have missed? What can I check? Papoteur

LXQt in Mageia 7, release 13.1


(Pedram Pourang) #2

Here, Print and Alt+Print work well with Screengrab. In your case, probably, Print is taken by a running program. For example, if you use openbox, check its config file.


(Papoteur) #3

Hi, I use Kwin, I don’t know what is the best. I was using KDE on this installation. KDE launches spectacle with this key.


(Pedram Pourang) #4

KWin is a good choice; I use it too and had disabled most of KDE shortcuts before – only the shortcuts that are related to the desktop cube and its rotation are active here.

I recommend you disable unneeded KDE shortcuts from systemsettings5 and then log out and log in.


(Papoteur) #5

Hello, I tried openbox, with no success. I tried to stop “Global shortcuts” in autostart section, without success. I came back to kwin, affected no action to Print key. Always without success, even after a reboot. On a side note, keys for brightness or sound doesn’t work either.


(Stefano) #6

You could try a moment a newly created user, just to verify. If it works there there IS a config file in your actual home conflicting. My guess: KDE, check those files:

~/.config/kdeglobals
~/.config/kglobalshortcutsrc
~/.config/khotkeysrc
~/.config/kwinrc
~/.config/plasma-org.kde.plasma.desktop-appletsrc
~/.local/share/kxmlgui5/katepart/katepart5ui.rc
~/.local/share/kxmlgui5/konsole/konsoleui.rc
~/.local/share/kxmlgui5/konsole/sessionui.rc
~/.local/share/kxmlgui5/kwrite/kwriteui.rc

(Papoteur) #7

Hi, I just tried with a test user, although it was already existing. With kwin, nothing happens by typing the Print key. With Openbox, it says me that gnome-something (don’t remember exactly the something part) can’t be found. Thus, the short key is OK, but not the application. In shortcuts panel, I don’t find anymore the entry for it.


(Papoteur) #8

Hello, I have renamed these files and restarted the session. The other files don’t seem to have something related to shortcuts or print. I’m still without effect of the Print key.


(Stefano) #9

I said “newly created”, if you used it already with some other DE it could have the same issue as your user.

For openbox with this other user check

cat ~/.config/openbox/lxqt-rc.xml |grep -i gnome


(Papoteur) #10

Hello, I solved my problem. The error was to try to use sreengrab. By installing lximage-qt and restoring the command, it was then OK, in kwin and in openbox. Now, I have to understand why the screengrab command exit without doing anything.


(Papoteur) #11

By reinstalling screengrab, it can now run. The executable was corrupted. This is the first time I see such a problem. Thus, completely solved :slight_smile: