No mouse functions on secondary monitor


(Sheriff Hobbes) #1

Hello,

I have found a strange bug regarding some LXQt applications. When moved to the secondary monitor, the mouse functions stop to work, i.e. when I right-click in the window, nothing happens, when I left-click on the tool bar, nothing happens. When I move the application window back to the primary monitor, everything is fine.

I experience this with:

  • PCManFM-Qt (always reproducable)
  • QTerminal (not always reproducable)

Using LXQT 0.14.1 on Debian 10.

Thanks, SH


(Pedram Pourang) #2

I don’t know about Debian but mouse is OK on secondary monitor with Arch and Manjaro. So, it can’t be an LXQt issue.

@agaida ?


(Chris Wyatt) #3

It’s probably unrelated, but I get a strange issue in my VirtualBox VMs sometimes (also running Lubuntu), where the mouse will occasionally only work in a specific region of the screen. When I click in the unclickable region, the other windows get deactivated, suggesting that something is picking up the click event. I feel like it’s a issue in the guest rather than the host, and sorts itself out if I log out and back in again.

Sorry, this is probably completely unrelated, but I figured it wouldn’t hurt to mention it.


(Pedram Pourang) #4

And you were right. Here is the right place to mention such problems; they shouldn’t be in the bug tracker.

Unfortunately, I have no idea about the root of your problem. I’ve tested LXQt with a second monitor a lot and have encountered no problem with mouse – but not with Debian.


(Alf Gaida) #5

unfortunatley i’m out of ideas too - xfwm4 should be able to handle it

never encountered problems.