No way to definetely set Compose key in Lubuntu 19.10


(LobaLuna) #1

Hi! I cannot set the Compose key. I have already tested to put a configuration in .xinitrc or in .xinputrc. I use:

setxkbmap -option compose:alt_caps 
setxkbmap -option shift:both_capslock

None of this is read, nothing is happening. Obviously I restarted after making any change, but nada.

However, if I run the command in terminal, I get my Compose key (and caps lock behavior) as intended.

How can I make these changes permanently?


(Stefano) #2

Just put them in a script (text file), make it executable and insert it in “startup applications” in “session settings”

#!/bin/bash
sleep 5 
setxkbmap -option compose:alt_caps 
setxkbmap -option shift:both_capslock

(LobaLuna) #3

Great idea! Not the one that I was expecting (a canonical one) but it’s great! Thanks!