PCManFM-Qt Right Click


(Alf Gaida) #21

maybe we should change the dependency structure and introduce some more fields in the control file. Right now we have only dependencies, recommends and suggests. Adding the fields Strong-Recommends, Really-Strong-Recommends and Really-Strong-Recommends-Really might help.

I think this would mess up the apt interface a bit too - but on the pro side it will hang the bar higher:

apt install $foo --no-install-recommends \
                 --no install-strong-recommends \
                 --no-install-really-strong-recommends \
                 --no-install-really-strong-recommends-really

Sarcasm ex. Colloquium.


(stefano) #22

Actually I have exactly the same issue, “Templates” I don’t use and it is set to my home.

Resolved by creating a “Template” folder in ~/Documents and setting the path.


#23

Yes, exactly right.

I created .NOTHING in my home directory and modified ~/.config/user-dirs.dirs to XDG_TEMPLATES_DIR="$HOME/.NOTHING". Seems XDG_TEMPLATES_DIR has to point to an actual directory or it keeps defaulting back to home. /dev/null wouldnt even work.

Weird all the discussion in this thread and the simple issue has such a simple resolution.


(Pedram Pourang) #24

You don’t read. Quoting myself: “his XDG user dirs may be a mess because…”.

Setting “Templates” to one’s home is an example of that mess. It doesn’t happen with a complete installation.


(Pedram Pourang) #25

As an Arch user, you take responsibility when you don’t install xdg-user-dirs (or maybe, another package) and so, your Templates dir is wrong… As you can see, that’s not the case with users of other distros.


(stefano) #26

It’s installed, the point was that I did never understand what this Template folder was meant for in the home, it was always the first I eliminated. In “Session settings > Path” I had just selected my home because you cannot select nothing…

I’m quite sure that the cluttering happened noto so much time ago, it’s some month I noticed it and I used it almost never. So I learned something today :wink:


(Pedram Pourang) #27

Then, for some reason, xdg-user-dirs-update was never called. My ~/.config/user-dirs.dirs says:

# This file is written by xdg-user-dirs-update
# ...
XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

As you know now, it’s a very useful folder. It extends simple file creation.


(stefano) #28

My file was updated this morning when I changed template path in session settings, but it differs: $HOME is /home/name and when I execute manually

xdg-user-dirs-update

it doesn’t add at the top

# This file is written by xdg-user-dirs-update

(Pedram Pourang) #29

I haven’t run xdg-user-dirs-update manually (and, right now, I don’t have time to check it) but its manual should contain useful information:

man xdg-user-dirs-update

(Pedram Pourang) #30

Although the problem mentioned here is NOT ours but is a result of bad XDG directories, it may be better to prevent user’s home from being a source for templates. My reason is that $HOME is meaningless as a templates dir.

If – and only if – that’s easy to do and doesn’t require lots of extra codes, I’ll open an issue and make a PR for it.