Pcmanfm-qt swich user command


#1

i installed pcmanfm on other desktop.
but “open as root” is not working with out root.
can i change the switch user command to work sudo command with out lxqt-sudo???


(palinek) #2

How exactly do you want to use the “plain” sudo w/o a terminal? The sudo/su frontends are used because of the nature of PCManFM-Qt -> it’s a GUI, the user is interacting with it in GUI manner. You are free to use gksudo, ksudo, pkexec


#3

in other desktop(Xfce) when i click open as root , it does not show password box.
with out installing lxqt -sudo package,can’t i use the xfce’s root password acking box??
IF i can how??
i saw a box in pcmanfm-qt->preferrence->advance->switch user command.i think it will do the work.but what do i write in here for xfce or other major desktop??


(palinek) #4

Use the google: https://www.google.com/search?q=xfce+sudo+frontend


#5

tried “gksudo” in the box but no solution


(palinek) #6

Such kind of statements doesn’t help anyone willing to help. Please, be more verbose about procedures, that you’ve taken or you will be left with your problem alone.


#7

i tried “gksudo” .but open as root still not working.


#8

it reply


(palinek) #9

Please, read carefully everything, what is written in the “Preferences” dialog, especially the note below “Switch user command”:
Examples: “xterm -e %s” for terminal or “gksu %s” for switching user.
%s = the command line you want to execute with terminal or su.


#10

i don’t wanted to open the folder in terminal.
i want to open the the folder as root in gui.


(Pedram Pourang) #11

Did you read palinek’s words above? If not, no one could help you.

If you can’t use sudo GUI front-ends, try this: sudo dbus-launch --exit-with-session pcmanfm-qt


#12

Realize this is an old conversation, but just wanted to add what I’ve found – the Tool --> Open as Root menu works perfectly in LXQt with both openSUSE and Fedora installations. But with my Arch installs, it still doesn’t. In fact, even from CLI, neither gksu or sudo would open pcmanfm-qt but instead generated errors. However, after editing the “Switch user command” in the Advanced section of Edit --> Preferences in the pcmanfm-qtmenu to: lxqt-sudo dbus-launch %s pcmanfm-qt opens in a new window perfectly with “Root Instance” clearly indicated. Not sure why this is still going on after two years though, or if there is a better workaround, but I’m glad this one works.


(Pedram Pourang) #13

In the latest git source, the default is changed to lxsudo dbus-run-session -- %s, which should work everywhere.