Qtermwidget: output symbols are shown as squares or not shown at all


(Kinoe) #1

@lxqt-team and supporters I’m running octopi -git, a pacman frontend from the AUR on Arch linux/ KDE Plasma. Octopi-git is using qterminal in qtermwidget as embedded terminal. But its output looks like this: https://imgur.com/vn9OROj It seems that all areas of potentially input of the embedded terminal= qtermwidget are ’ squared '. All other areas particular of pure output are fine. Strange that qterminal used as standalone works flawlessly?! I tried quite a few things: aarnt/octopi#401 Is this familiar to someone here? Any ideas would be appreciated… 'cause this is a tough one.

KDE Plasma Version: 5.17.3 KDE Frameworks Version: 5.64.0 Qt Version: 5.13.2 Kernel Version: 5.3.12-arch1-1 Qtermwidget-git version: 0.14.1.47.gd4896ed-1 Qterminal-git version: 0.14.1.75.g1ce29eb-1


(Pedram Pourang) #2

You may want to report the issue to Octopi’s developer.


(Kinoe) #3

@tsujan actually I did report this issue to Octopi’s developer: https://github.com/aarnt/octopi/issues/401. He himself asked me to turn to the developers of Qtermwidget for help or ideas.


(Pedram Pourang) #4

My bad; I didn’t see the report link.

I use QTerminal a lot but have never encountered the problem in your screenshot. Sorry, I have no clue… I thought Octopi’s developer might have an idea because he knows how Octopi uses qtermwidget.


(Pedram Pourang) #5

I didn’t find a similar problem by searching in the (open or closed) issues but you might want to look deeper into them: https://github.com/lxqt/qterminal/issues


(Kinoe) #6

I found the problem… it is sitting 2ft in front of the monitor :wink: Once I installed manually a font called ‘Monospace.ttf’ which perhaps was in conflict with font.setFamily("Monospace") in qtermwidget.h or with other fonts of the monospace family because itself isn’t a monospace font! Anyway, uninstalling it solved the problem! Really sorry for bothering you!