Raspberry Pi4 LXQt (64-bit)

lubuntu

#1

Even though the Raspberry Pi4 has a 64-bit processor Raspbian (the official OS by the Pi Foundation) by default is 32-bit for compatibility with other Pis. The benefits of running a 64-bit OS should be better performance (USB, Ethernet) and 64-bit applications. There is an experimental Pi4 64-bit Raspbian kernel in testing but what 64-bit LXQt images are available now?

Ubuntu 19.10 is now officially supported on the Raspberry Pi4 with a 64-bit (Ubuntu Server) image.

I downloaded the 64-bit image which is a minimal Ubuntu ARM Pi4 image and flashed it to a microSD card. On first log-in you are asked for a user and password. Enter “ubuntu” for the user and “ubuntu” again for the password and then enter a new password.

Then upgrade

sudo  apt-get upgrade

Ubuntu suggests installing the LXQt desktop using

sudo apt-get install lubuntu-desktop

The Lubuntu PPA which I originally used to install LXQt is now disabled (link removed).

Running uname -a shows that 64-bit Ubuntu is running on the Pi4.

I then experimented by installing Organizer from source.

You need to install the developer packages: build-essential, qt5-default, qtcreator, automake, checkinstall, cmake, libqt5svg5-dev, libqt5*-dev, qttools5-dev, libkf5plasma-dev, liblxqt0-dev etc. Then follow the install from source instructions from the Organizer github page:

I had to log in and out (to set up the database) to run Organizer (see screenshot below).

An alternative 64-bit ARM Raspberry Pi4 LXQt distro is that provided by Manjaro (Arch).

This is an image which can be directly flashed to a microSD card. The install process requires setting a user name, user password, root password, time zone, locale and host name. Once logged into Manjaro then upgrade using

sudo  pacman -Syu

The yay AUR helper can be installed (see video below)


(Shrinivas Kumbhar) #2

an aur package for lxqt-organizer

https://aur.archlinux.org/packages/lxqt-organizer-git/


(Walter Lapchynski) #3

Or you could just install the image and sudo apt install lubuntu-desktop^ sddm and have a fairly normal Lubuntu setup ready to use out of the box…


#4

I found that using “sudo apt-get install lubuntu-desktop” did not work for me resulting in a number of “failed to fetch” errors. This is why I added the lubuntu PPA. Strangely after an update I now have the gdm (gnome display manager) installed together with a minimal gnome desktop along side lxqt. I will look at the simple desktop display manager sddm. I checked the current display manager with

cat etc/X11/default-display-manager

which returned usr/bin/gdm3


#5

Librewish thanks for creating this package. I now have Manjaro ARM lxqt image written to a micro SD card and running on my Raspberry Pi 4 (its great). I did an update using “pacman -Syu” but when using “sudo pacman -S lxqt-organizer” I got a “target not found” message. As you can probably tell I am not an arch user and so apart from installing “base-devel” I need to work out how to install all the other dependencies to build Organizer from source on Manjaro. I am not sure if I should say this on this forum but people are telling me that Manjaro ARM KDE plasma for the Pi 4 is also fantastic and so this image is on my radar for testing some time in the future. By the way I have changed the name from lxqt-organizer to just organizer when I changed (and improved) the calendar interface. I am working on themes in the latest version (v005) from issues that I have picked up from testing on different distros. Hopefully I should finish the code in the next few weeks to get v005 released.


(Stefano) #6

I dunno why you added this ppa that contains lot of stuff from 2010 and 2011…

And lxqt-organizer exists only on AUR, so you would need an aur helper to install it, like yaourt or other.


(Pedram Pourang) #7

@crispinalan Have you read https://github.com/lxqt/organizer/issues/10 ?


(Pedram Pourang) #8

@crispinalan Now that your read this page at least, I repeat what was said in that report.

There is a standard way of adding commits to an LXQt app. The way you do it is far from it.


(Walter Lapchynski) #9

You want to know the most common reason for this? Networking issues.

That PPA is so outdated it’s not even funny. There’s almost nothing there that even had to do with LXQt. I’ve now disabled it and deleted all the packages so no one else gets similarly confused.


(Stefano) #10

“lxqt-desktop” does not exist, “lubuntu-desktop” does. To have core components install “lxqt” (in ubuntu 19.10)


#11

Thanks. I used yay to install lxqt-organiser (yay -S lxqt-organizer) on my Manjaro ARM lxqt Pi 4 image. See screenshot. This is great as I can now test the application on both Debian and Manjaro Arch as I make code changes.


#12

My network connection is good thanks. I tried again installing the Ubuntu 19.10.1 server rpi4 image (64-bit ARM) and then using “sudo apt-get install lubuntu-desktop” to install the LXQt desktop (as suggested on the Ubuntu page) and still ended up with missing packages. I agree that the PPA system on Ubuntu appears to be out dated. Do you know of a Lubuntu ARM lxqt rpi4 image similar to the type image provided by Manjaro?


#13

I will look into this.


#14

Update: I have tried yet again installing Ubuntu server (64-bit) for the rpi4 and then “sudo apt-get install lubuntu-desktop” and rebooting. This time I get a minimal gnome desktop (terminal and a few other tools). I have removed the link to the PPA.


(Walter Lapchynski) #15

Of course, there are two sides to any network connection. And there are such things as ephemeral issues which come and go. I wouldn’t be so sure of yourself unless you’ve done the tests. Another possible cause: if you didn’t first sudo apt update.

Actually I think I just figured out the issue with the lubuntu-desktop metapackage. In the tree of dependencies, there’s one for a polkit authentication agent and because of the order of installation and the fact that lxqt-polkit is not a direct depend of the metapackage, you get gnome-shell instead and with it all of the other GNOME crap. So if you sudo apt install lubuntu-desktop lxqt-polkit it should work. You’ll get sddm but you could always swap it with something else.

I’ll work on fixing the packages shortly.


#16

Thanks for the update. I will use the Manjaro ARM 64-bit rpi4 image while the lubuntu-desktop metapackage gets fixed.


(Alf Gaida) #17

it’s easy - just try plain debian - the minimal iso and apt install task-lxqt-desktop should be enough - nothing against lubuntu, but they have sometimes strange ideas about working systems


(Walter Lapchynski) #18

Kind of reminds me how a certain LXQt contribubtor has strange ideas about what other distros ideas are, but hey, he survived the 70s, so cut him some slack. :rofl:

Anyways… fixed in 20.04.


#19

I can confirm that the lubuntu-desktop metapackage is now fixed and I have flashed an Ubuntu ARM 64-bit Pi4 image to a microSD card and then installed LXQt desktop using the instructions above. See screenshot below.


(Walter Lapchynski) #20

Glad all is working now.

P.S. The problem was caused by GNOME developers and the ever-changing dependencies of their packages.