Shortcuts and Alt key


Hi, I have just installed lubuntu. I need to use some program that uses shortcuts such as Alt-V, but when I type that, it is captured by the window’s menu. So I need to stop the mane from capturing that combination of keys (I would prefer no to capture any combination). But I cannot find a way t odo it. Can anybody pint me where to do that?


(stefano) #2

I don’t know actually which WM is used in Lubuntu, but it’s enough to remove the shortcut from its config file, if the window manager is openbox it should be one of the files in ~/.config/openbox, if Lubuntu uses xfwm there is a section for editing shortcuts in its configuration tools.

(Alf Gaida) #3

in bug @wxl wrote:

but at least as far as I can tell, Openbox is the canonical window manager of LXQt.

We don’t agree, it might be Lubuntus Canonical choice, but we prefer it like this (as @tsujan correctly answered:

Even if that’s said in some LXQt doc (is it?), it’s wrong (and should be removed from that doc). LXQt doesn’t have a special relationship with Openbox.

(Alf Gaida) #4

The solution is:

  • configure your WM of choice well (keybindings and mappings included)
  • configure lxqt-globalkeys well
  • be done with it

EDIT: I really couldn’t resist the ‘canonical’ joke. My bad :dark_sunglasses:


Thanks for your reply. I tried commenting out the entire file, but the menu still captures the alt key. I think I could obtain the result I want in a previous version of lubuntu, by just setting an option to disable shortcuts but I cannot find it here.

LXQt version is 0.13.0, Qt: 5.11.1

(Alf Gaida) #6

genuine Lubuntu 18.10 ?


Yes, Lubuntu 18.10 I think modifying the configuration files i could disable almost every shortcut. But the terminal emulator keeps capturing the keys.

(Alf Gaida) #8

normal and expected behaviour i would guess.

(AndreaS) #9

With Alt-V don’t forget that the currently active application might catch that one too, as it is common for applications with a menu that triggers on Alt and a menu option that triggers on Alt-V, for instance for “View”.