[SOLVED] Openbox/LXQT Keyboard Shortcuts


#1

Dear all,

I updated my Lubuntu18.04 (LXDE) to Lubuntu18.10 (LXQT) yesterday. So far I like it.

However there is one thing I am missing. I had a lot of shortcuts configured on openbox, for opening programs and to do window tiling. None of them work on LXQT. I only found a GUI to configure keyboard shortcuts. And I have not seen tiling options there neither.

There is an option to use the Openbox shortcuts file instead?

Also, the ‘click’ on trackpad on my laptop did not work, although five minutes in Google sort that out…

Also, during the installation process, I did not have the option to install “third parties drivers” as I was used to. I had no time to check if they were installed or not…

And no option to update during installation, which I did manually straight away.

I understand that this is work in progress, and for me (15 years linux user) is not the end of the world, but for a new comer, these are the type of things that will scare them away…

Anyway, coming back to the point of this post: Can any body give me a hint of how to set-up tiling short-cuts in LXQT? Alternatively (even better for me), can anybody tell me how to use the openbox rx.xml file instead of globalkeyshortcuts.conf file?

Thanks in advance, Jofre


(stefano) #2

When using a LXQt session with openbox you have to edit ~/.config/openbox/lxqt-rc.xml

Trackpad and third parties driver issue are not related to LXQt.


#3

Dear Stefonarch,

Sorry, I wrote rc.xml, but I did modify the lxqt-rc.xml file. LXQT does not completly ignore this file, as the window borders and icons changed when I did remplaced my Lubuntu18.04 xml file, but the keyboard shortcuts were not working…

Thanks for trying anyway! Jofre

PS: you are right, my other comments should have been directed to the Lubuntu team and not to the LXQT people. My apologies.


#4

Dear all,

I found the solution!!!

Menu–> Preferences --> LXQT Settings --> Session Settings --> Autostart --> Disable “Global Keyboard Shortcuts”

Then logout and login back. Now, it is the lxqt-rc.xml file that is in charge!

All the best, Jofre


(stefano) #5

Can this be an Lubuntu thing? I never saw this in autostart.