Unthemed GTK applications [SOLVED]


#1

I’m on OpenBSD 6.4 with LXQt 0.13.0. GTK applications (e.g., filezilla, deluge) are completely unthemed, even though I ran lxappearance and chose a theme I know supports both gtk2 and gtk3.

After running lxappearance I can see that both ~/.gtkrc-2.0 and ~/.config/gtk-3.0/settings.ini exist and appear to have sufficient settings.

Please, what am I missing?


(P L Lucas) #2

In LXQt appearance, can you select the GTK2 theme?


#3

No, in DesktopSettings -> LXQt Settings -> Appearance (lxqt-config-appearance) there is no mention of GTK settings of any kind.

Is there an extra package I should install in order for GTK settings to show up there?


(Alf Gaida) #4

@selairi - *BSD has and old and far outdate LXQt - even debian is faster :stuck_out_tongue:

@puffyUberAlles - updating to 0.14.1 would solve the most of the issues, second: read about matching icon themes - i suggest oxygen, breeze, faenza, papirus. And using lxappearance is a really bad idea.


(Jesper Schmitz Mouridsen) #5

FreeBSD has 0.14.0


(Pedram Pourang) #6

Shouldn’t be much different from 0.14.1 in this special case.


#7

I was missing the “engine” required by my theme. After installing the package gtk-engines2, everything magically started working.

So all the required ingredients were:

  1. a gtk theme that supports gtk2 and gtk3

  2. lxappearance package, which created ~/.gtkrc-2.0 and ~/.config/gtk-3.0/settings.ini based on what the user chooses in lxappearance

  3. the “engine” required by the theme (in my case it was the clearlooks engine, available in the gtk-engines2 package)