Unwanted folders appear on desktop


#1

One thing I’ve always liked about LXQt is that there are no folder icons on the desktop by default. There is an option to enable the Home directory and Trash on the desktop. This is exactly how I would have designed it. I have around ten LXQt installations on several distros, two with VirtualBox, and none have ever had folder icons on the desktop. Recently I installed LXQt in ArcoLinuxD on a NUC6CAYH for a friend which is now about about 7000 km away. Looking at this person’s desktop via video chat, I noticed that all the main directories in the home directory, Downloads, Documents, etc., now had folder icons showing up on the Desktop at the left, arranged vertically. At first I thought the user may have inadvertently copied these folders into the Desktop folder in pcmanfm-qt. However, this is not the case, as any attempt to move the folder icons on the Desktop to the trash also removes them from the user’s Home directory. In other words, the folders on the desktop are one and the same as those in the directory. Researching the issue, most of what I could gather was historical, for much earlier LXQt versions. For these earlier versions the following was typical of the advice I found:

“Create an empty folder on the desktop (give it a name, ex: blank desktop), then from Session Settings click User Directories and look for the section at the top “Desktop”, click the folder icon and have it point to your new /home/user/Desktop/[blank desktop] folder. After this you should now be the proud owner of a clean desktop with no folders or icons, and PCManFM still in control of the desktop (wallpapers etc…).”

I don’t wish to follow this advice as it has never been necessary for me. I need to know two things:

  1. What triggered the creation of these folders on the desktop, and
  2. How might I get rid of them? Thanks for any suggestions.

(Pedram Pourang) #2

Then, ArcoLinuxD may have a serious problem. Maybe they’ve chosen Home as the desktop path, in which case, you could report that to their bug tracker. But first check whether it wasn’t something you did inadvertently.


(Pedram Pourang) #3

More specifically: Go to Session Settings → User Directories and make sure they are correct.


#4

Thanks for the reply, tsujan. I had the computer in my hands about a week and didn’t encounter any problem and things were fine when I handed it over. I also have the same AcroLinuxD system installed in VM, same apps and language, to be able to track problems. I also have LXQt installed on a Chuwi laptop with AcroLinuxD. I have not seen this issue in either place, so am not suspecting AcroLinuxD. As I mentioned, the computer is in the hands of another user now and this issue appeared. What I would like to know is what this user could have done inadvertently (as you mentioned checking) that would trigger this. Appreciate any ideas.


#5

Yes, I checked User Directories. I will re-check.Thanks.


(Pedram Pourang) #6

The user may have changed Session Settings → User Directories, edited config files manually or overwritten them with other files. These things cannot happen automatically.


(Pedram Pourang) #7

Please also note that you could make any folder as your desktop. The default (and best) folder is ~/Desktop, of course. In this case, ~ has been chosen as desktop.

NOTE: ~ should be replaced by /home/USER_NAME.


#8

It’s a big mystery to me. I was very surprised to see it! Never before. But I set up computers as a kind of charity, focus is on low resource use and simplicity, and I’ve found every user is different. I’m surprised what problems come up sometimes, things that never came up for me. This particular user just wants to surf the web, use LibreOffice, Zoom, and GIMP, and very very unlikely knows anything about config files, let alone attempt to edit them. Anyway, you seem surprised at this too, and that tells me something I didn’t know before. Appreciate the guidance.


#9

BTW, as I mentioned before, I have same set up in a VM specifically for troubleshooting, so if you know of anything that might set off this problem, let me know, and I’ll attempt to re-create the problem there.


(Pedram Pourang) #10

Don’t be :wink: Once, I set up a Linux installation for a friend of mine. The next time he brought his laptop to me, I decided not to do it again. He had turned a clean installation into a monstrosity. Some people are very capable of that.

Only a user’s magic, like the above story.


#11

In life, I’m fine with a little mystery, like it in fact, but mystery is unwanted on my desktop. So I thought I’d post the solution I found for this as a service to anyone else might ever need it.
I installed this ArcoLinux system in English and then later changed the locale over to Japanese, which I read but isn’t my native language. It turned out the locale change was not 100% effective. In pcmanfm-qt the list of places on the left all rendered perfectly in Japanese, but the directories themselves, such as Desktop, Documents, Downloads,etc remained in English. My friend changed them to Japanese by right clicking and renaming them to be the same as they were in places. LXQt didn’t carry over these changes but left them as XDG_DESKTOP_DIR="$HOME" etc. My friend was able to input the desired Japanese terms in LXQt Session Settings under User Directories and didn’t need to directly edit the user-dirs.dirs configuration file. This had the expected result of removing the folder icons from the desktop.


(Pedram Pourang) #12

That will render them useless. Of course, you could rename any file/folder but Documents, Download and Desktop (as well as many other folders) are special. For example, when you rename Desktop, you actually remove your desktop.

Instead, please contribute to the LXQt translation and make it more complete!


#13

Actually, with the tweaks I mentioned, it’s working as one would expect. The Desktop folder has even reverted to its original, unique shape (as distinct from other folders). Of course, it’s best if it all changed over automatically through change in Locale.

Instead, please contribute to the LXQt translation and make it more complete!

How to do?


(Alf Gaida) #14

Just try: https://weblate.lxqt.org - please reach back if you don’t know the component. Tbh - we will be pleased by every improvement in any translated component :smiley:


#15

I’ve checked out the link. It seems Japanese is pretty much covered, so I’m not sure where I could help. My native language is English, not Japanese, so I usually do Japanese to English translation and not vice-versa. But I have confidence in translating words or short phrases. I’d be happy to start with the folder names we spoke of, Desktop, Downloads, and so on, but what category would they be in? Also is there a forum or somewhere where this (translation, etc) is specifically being discussed and worked on? Or a wiki maybe? Clearly this isn’t the forum for it so I don’t want to take up more space here. Just point me in some good directions. Thanks.