Xss-lock, i3lock, and xdg-screensaver: return code 9


(Diego Cano) #1

I understand my situation is a bit bizarre, and the issue might not be due to lxqt, but then again, it might.

So, I do not want to use xscreensaver, since I don’t actually need a screensaver, just a screen locker. I’ve actually been using i3lock for some time, and I’m satisfied with it. I’ve set it up with xss-lock so it’s launched automatically when the screen turns off.

However, each time it happens, I also have an error window from lxqt saying that xdg-screensaver couldn’t “activate” the screensaver - since there isn’t any.

So I started looking, and found a patch for xdg-screensaver to find and use xss-lock. Installed it, and everything works peachy from the CLI. The patch is being reviewed by the xdg-screensaver team and might become part of the standard code soon, by the way.

However, if I click on “Lock screen” on the LXQt menu, I get an error window with the message (I’m translating from Spanish, so it might actually be a bit different): “Unkown error - undocumented return value from xdg-screensave: 9” (it does indeed say screensave instead of screensaver). It does NOT lock the screen, by the way.

I would just like to be able to lock my screen without errors, so I’d appreciate any idea on how to a) turn off the lxqt – xdg-screensaver connection without uninstalling xdg-utils; b) change this 9 return value; or c) make lxqt accept the return value

PS: I’ve tried substituting i3lock by physlock with the same result - so the 9 value does not come from it.

Edit: New data, there’s is no error when I suspend the machine. This is good enough for me. Sorry for the trouble.


(Ringo32) #2

lxqt using xdg-utils basicly in aur arch there is an xdg-utils-slock that uses slock. But basicly you can do this :

like : https://wiki.archlinux.org/index.php/LXQt#Customizing_Leave

copy that from /usr/share/applications and copy to your .local/sahre/applications

edit those file and it uses slock whatever you like.

i am using slock.