Yad system tray woes


#1

I’m on OpenBSD 6.4 with LXQt 0.13.0 and yad 0.40.0

I rely on yad pretty heavily but have noticed that it has the following 4 issues when it interacts with the LXQt system tray:

  1. Not all stock icons can be displayed on the system tray (e.g., dialog-error displays but not dialog-ok)

  2. No icons at all display in the right-click menu

  3. For the system tray icons that do display (e.g., dialog-error), sometimes (not often) superfluous pixels show up behind and around the icon.

  4. Whenever ‘yad --notification…’ runs, a warning is logged in ~/.config/lxqt/debug.log:

2019-04-11 22:40:45.394 (0x7f7ffffcac80) Warning:     * Error image is NULL

This command reproduces problems #1 and #4 (only a white placeholder icon shows up in system tray):

yad --notification --image='dialog-ok'

This command reproduces problems #2 and #4 (appropriate icon shows up in system tray, but no icon at all in right-click menu):

yad --notification --image='dialog-error' --menu='Test!quit!dialog-error'

Problem #3 happens randomly and cannot be intentionally reproduced.

Someone experiencing #3 and #4 with a different application reported it here, but I don’t know enough about Qt or LXQt to draw any helpful conclusions from the discussion.

I reported these issues to the yad developer on GitHub, but we have not made any progress toward a solution. Please, are my 4 issues related? Is/are there fix(es)? I’m guessing it has something to do with the fact that yad is a gtk application while LXQt is a Qt desktop environment. Maybe all I need is to add a gtk setting or gtk-related environmental variable in order for yad and lxqt-panel to get along well?

(In case this additional information is helpful: I have a different laptop with identical hardware, OS version, and yad version–only difference is that has MATE instead of LXQt. That system has none of the four issues. Nevertheless, I’d like to find a solution because I like LXQt better and it’s my daily driver.)


#2

Update: installing lxappearance then, within the application, choosing an icon theme and checking “show images in menus” solved problems #1 and #2.

Issue #4 (the warnings in debug.log) are still there. Issue #3 comes and goes, so hard to say if it’s still an active problem.


#3

I can confirm that issue #3 is still ongoing (sometimes extraneous pixels creep into yad’s system tray icon). It happened again.

So setting GTK theme fixed issues #1 and #2, but yad issues #3 and #4 are both still unsolved (and identical to what reported here affecting a different application). Any insights into cause/fix?